aboutsummaryrefslogtreecommitdiffstats
path: root/community/davfs2/010-main_code_fix.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-10-09 09:15:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-10-09 09:15:07 +0000
commit5d25620045e4d0148fae1120f42afb81655cf5bc (patch)
tree3d86b32e3268fd3158029dad32bc3544e64a3eec /community/davfs2/010-main_code_fix.patch
parent49c32f60818a73963b03f206880023d63dfb44a8 (diff)
downloadaports-5d25620045e4d0148fae1120f42afb81655cf5bc.tar.bz2
aports-5d25620045e4d0148fae1120f42afb81655cf5bc.tar.xz
community/davfs2: move from testing
Diffstat (limited to 'community/davfs2/010-main_code_fix.patch')
-rw-r--r--community/davfs2/010-main_code_fix.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/davfs2/010-main_code_fix.patch b/community/davfs2/010-main_code_fix.patch
new file mode 100644
index 0000000000..aa36fdfaa7
--- /dev/null
+++ b/community/davfs2/010-main_code_fix.patch
@@ -0,0 +1,35 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -32,8 +32,8 @@ mount_davfs_SOURCES = cache.c dav_coda.c
+ kernel_interface.h mount_davfs.h webdav.h
+ umount_davfs_SOURCES = umount_davfs.c defaults.h
+
+-AM_CFLAGS = -Wall -Werror=format-security \
+- -fstack-protector --param=ssp-buffer-size=4
++AM_CFLAGS = -Wall -Werror=format-security
++# -fstack-protector --param=ssp-buffer-size=4 -- removed ssp not supported in openwrt
+ DEFS = -DPROGRAM_NAME=\"mount.davfs\" \
+ -DDAV_SYS_CONF_DIR=\"$(pkgsysconfdir)\" \
+ -DDAV_LOCALSTATE_DIR=\"$(dav_localstatedir)\" \
+--- a/src/cache.c
++++ b/src/cache.c
+@@ -58,7 +58,7 @@
+ #ifdef HAVE_SYS_TYPES_H
+ #include <sys/types.h>
+ #endif
+-#include <sys/xattr.h>
++#include <linux/xattr.h>
+
+ #include <ne_alloc.h>
+ #include <ne_string.h>
+--- a/src/webdav.c
++++ b/src/webdav.c
+@@ -2033,7 +2033,7 @@ ssl_verify(void *userdata, int failures,
+ len = getline(&s, &n, stdin);
+ if (len < 0)
+ abort();
+- if (rpmatch(s) > 0)
++ if ((s[0]=='y' || s[0]=='Y') > 0)
+ ret = 0;
+ free(s);
+ }