aboutsummaryrefslogtreecommitdiffstats
path: root/community/deadbeef
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-27 20:45:45 -0300
committerprspkt <prspkt@protonmail.com>2019-04-28 17:40:02 +0300
commit44f7c917afeecbf3a816474a2281f07bb3d49909 (patch)
treee90ebc7b7e17ea349e4328e50a03b6cb1a798a1d /community/deadbeef
parent2bd004d05e9f9f23d98f670befcd74b0d05498df (diff)
downloadaports-44f7c917afeecbf3a816474a2281f07bb3d49909.tar.bz2
aports-44f7c917afeecbf3a816474a2281f07bb3d49909.tar.xz
community/deadbeef: upgrade to 1.8.0
- Fix license - Disable static library - Remove superfluous builddir= assignment and cd statements - Add support for libsndfile and opus files - Add patch to fix build
Diffstat (limited to 'community/deadbeef')
-rw-r--r--community/deadbeef/APKBUILD48
-rw-r--r--community/deadbeef/arm-buildfix.patch52
-rw-r--r--community/deadbeef/strdupa.patch17
-rw-r--r--community/deadbeef/use-endian-h.patch11
4 files changed, 36 insertions, 92 deletions
diff --git a/community/deadbeef/APKBUILD b/community/deadbeef/APKBUILD
index 54e2586fe2..54762278c4 100644
--- a/community/deadbeef/APKBUILD
+++ b/community/deadbeef/APKBUILD
@@ -2,46 +2,36 @@
# Contributor:
# Maintainer:
pkgname=deadbeef
-pkgver=0.7.2
-_ver=${pkgver/_rc/-rc}
-pkgrel=4
+pkgver=1.8.0
+pkgrel=0
pkgdesc="fairly capable playlist-oriented audio player"
url="http://deadbeef.sourceforge.net/"
arch="all"
-license="GPL"
-depends=
-depends_dev="gtk+-dev libmad-dev alsa-lib-dev ffmpeg-dev libsamplerate-dev
- gettext-dev flac-dev libvorbis-dev jansson-dev curl-dev"
-makedepends="$depends_dev intltool gettext"
-install=""
+license="Zlib GPL-2.0-or-later LGPL-2.1-or-later"
+depends="desktop-file-utils hicolor-icon-theme"
+depends_dev="gtk+3.0-dev libmad-dev alsa-lib-dev ffmpeg-dev libsamplerate-dev
+ gettext-dev flac-dev libvorbis-dev jansson-dev curl-dev opusfile-dev
+ libsndfile-dev"
+makedepends="$depends_dev intltool gettext bsd-compat-headers"
subpackages="$pkgname-dev $pkgname-lang $pkgname-doc"
-source="https://downloads.sourceforge.net/project/$pkgname/$pkgname-$_ver.tar.bz2
- arm-buildfix.patch
- use-endian-h.patch"
+source="https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
+ strdupa.patch"
options="!check"
-builddir="${srcdir}/${pkgname}-$_ver"
-
-prepare() {
- update_config_guess || return 1
- default_prepare
-}
-
build() {
- cd "$builddir"
- CXXFLAGS="$CXXFLAGS -std=gnu++98" \
- ./configure --prefix=/usr \
+ ./configure \
+ --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info || return 1
- make || return 1
+ --infodir=/usr/share/info \
+ --disable-oss \
+ --disable-static
+ make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-sha512sums="9ea61a3820d9d57f038b80652ce63bd87e6781259c0f58a93b70607b02e71debbf5598f4a06d607d3840a804c3b7fc5039a4c4b0a8bb01e8e5107bba3f0bd980 deadbeef-0.7.2.tar.bz2
-57e25e3478b5516f0ebc34fa561c619bdca4cdf7e9f6dc1d81317c972b10bd073a4a761dfc2327047fd56433e79ff57bf501c9cfe77079c450b46f5a0315555b arm-buildfix.patch
-8a918b75ad20689cfa0c0fd073ca96377311c95a6fff55cf6939a77ce9911bc7dfed024d825f5bdaa639988864d3b6b2707697f75ce5e28b747b1a190e55e39d use-endian-h.patch"
+sha512sums="c39fc34bcd70ac745ce9c5ac6f4f4535d07d47906dd297bc598e850178e46ab8e933cd11e04e71b9432462c7a1e36f4a8ead3a50f0bb15a696c3961c336611ad deadbeef-1.8.0.tar.bz2
+902c65cc5fd39f9935080a7f5df6d7c17fb366706501957a6b54d796f1b7b64a03fed64f93c9149d9332c4638de35254d526c031af0cd12674efb8d25dff31e1 strdupa.patch"
diff --git a/community/deadbeef/arm-buildfix.patch b/community/deadbeef/arm-buildfix.patch
deleted file mode 100644
index 5776b9225a..0000000000
--- a/community/deadbeef/arm-buildfix.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-diff --git a/plugins/adplug/adplug/s3m.cpp b/plugins/adplug/adplug/s3m.cpp
-index 173a756..2158bae 100644
---- a/plugins/adplug/adplug/s3m.cpp
-+++ b/plugins/adplug/adplug/s3m.cpp
-@@ -26,7 +26,7 @@
- #include <string.h>
- #include "s3m.h"
-
--const char Cs3mPlayer::chnresolv[] = // S3M -> adlib channel conversion
-+const signed char Cs3mPlayer::chnresolv[] = // S3M -> adlib channel conversion
- {-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,0,1,2,3,4,5,6,7,8,-1,-1,-1,-1,-1,-1,-1};
-
- const unsigned short Cs3mPlayer::notetable[12] = // S3M adlib note table
-diff --git a/plugins/adplug/adplug/s3m.h b/plugins/adplug/adplug/s3m.h
-index cf58c44..a00404c 100644
---- a/plugins/adplug/adplug/s3m.h
-+++ b/plugins/adplug/adplug/s3m.h
-@@ -92,7 +92,7 @@ class Cs3mPlayer: public CPlayer
- char filetype[30];
-
- private:
-- static const char chnresolv[];
-+ static const signed char chnresolv[];
- static const unsigned short notetable[12];
- static const unsigned char vibratotab[32];
-
-diff --git a/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.cpp b/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.cpp
-index 29b5c90..55dd167 100644
---- a/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.cpp
-+++ b/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.cpp
-@@ -81,7 +81,7 @@ const int8_t XSID::sampleConvertTable[16] =
- '\x08', '\x19', '\x2a', '\x3b', '\x4c', '\x5d', '\x6e', '\x7f'
- };
- */
--const int8_t XSID::sampleConvertTable[16] =
-+const uint8_t XSID::sampleConvertTable[16] =
- {
- '\x80', '\x94', '\xa9', '\xbc', '\xce', '\xe1', '\xf2', '\x03',
- '\x1b', '\x2a', '\x3b', '\x49', '\x58', '\x66', '\x73', '\x7f'
-diff --git a/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.h b/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.h
-index 98171d7..9dee5e3 100644
---- a/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.h
-+++ b/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.h
-@@ -234,7 +234,7 @@ private:
- uint8_t sidData0x18;
- bool _sidSamples;
- int8_t sampleOffset;
-- static const int8_t sampleConvertTable[16];
-+ static const uint8_t sampleConvertTable[16];
- bool wasRunning;
-
- private:
diff --git a/community/deadbeef/strdupa.patch b/community/deadbeef/strdupa.patch
new file mode 100644
index 0000000000..dd0a60c17d
--- /dev/null
+++ b/community/deadbeef/strdupa.patch
@@ -0,0 +1,17 @@
+musl strdupa() fails to compile in c++ due to a missing cast
+use deadbeef's fallback version instead
+
+--- a/strdupa.h
++++ b/strdupa.h
+@@ -26,6 +26,10 @@
+
+ #include <string.h>
+
++#if defined(__linux__) && !defined(__GLIBC__)
++# undef strdupa
++#endif
++
+ #ifndef strdupa
+ # define strdupa(s) \
+ ({ \
+
diff --git a/community/deadbeef/use-endian-h.patch b/community/deadbeef/use-endian-h.patch
deleted file mode 100644
index 1fd35b7eb1..0000000000
--- a/community/deadbeef/use-endian-h.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/plugins/gme/game-music-emu-0.6pre/gme/blargg_endian.h
-+++ b/plugins/gme/game-music-emu-0.6pre/gme/blargg_endian.h
-@@ -21,7 +21,7 @@
- // BLARGG_BIG_ENDIAN, BLARGG_LITTLE_ENDIAN: Determined automatically, otherwise only
- // one may be #defined to 1. Only needed if something actually depends on byte order.
- #if !defined (BLARGG_BIG_ENDIAN) && !defined (BLARGG_LITTLE_ENDIAN)
--#ifdef __GLIBC__
-+#ifdef __linux__
- // GCC handles this for us
- #include <endian.h>
- #if __BYTE_ORDER == __LITTLE_ENDIAN