aboutsummaryrefslogtreecommitdiffstats
path: root/community/dircproxy
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2016-10-31 07:33:12 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2016-10-31 07:33:24 +0000
commit5ede648bb14d6fde854832d2c633b777797fb879 (patch)
treeed146050fc2c78b93d0754bc367cf68f21cbe711 /community/dircproxy
parent61d3fafd055aff8f7e62251ef583679536feb2a2 (diff)
downloadaports-5ede648bb14d6fde854832d2c633b777797fb879.tar.bz2
aports-5ede648bb14d6fde854832d2c633b777797fb879.tar.xz
community/dircproxy: move into community
Diffstat (limited to 'community/dircproxy')
-rw-r--r--community/dircproxy/APKBUILD66
-rw-r--r--community/dircproxy/fix-gcc4-issue.patch63
-rw-r--r--community/dircproxy/fix-issue54-1.patch22
-rw-r--r--community/dircproxy/fix-issue54-2.patch22
-rw-r--r--community/dircproxy/fix-segfault.patch25
5 files changed, 198 insertions, 0 deletions
diff --git a/community/dircproxy/APKBUILD b/community/dircproxy/APKBUILD
new file mode 100644
index 0000000000..05042040d6
--- /dev/null
+++ b/community/dircproxy/APKBUILD
@@ -0,0 +1,66 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=dircproxy
+pkgver=1.2.0_rc
+_status=${pkgver/_rc/-BETA}
+_ver=${_status//./_}
+pkgrel=1
+pkgdesc="IRC proxy server designed for people who use IRC from lots of different workstations or clients"
+url="https://github.com/w8tvi/dircproxy"
+arch="all"
+license="GPL"
+depends=""
+makedepends="autoconf automake"
+install=
+subpackages="$pkgname-doc"
+source="$pkgname-$_ver.tar.gz::https://github.com/w8tvi/dircproxy/archive/RELEASE-$_ver.tar.gz
+ fix-gcc4-issue.patch
+ fix-segfault.patch
+ fix-issue54-1.patch
+ fix-issue54-2.patch
+ "
+
+_builddir="$srcdir/$pkgname-RELEASE-$_ver"
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ ./autogen.sh
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="fbff23c43845e5a6c0bdc8d439186af3 dircproxy-1_2_0-BETA.tar.gz
+c407e3111510dc86347826d922d3d292 fix-gcc4-issue.patch
+65adeaa67ccbbea5f98a6f8b2b0b32f0 fix-segfault.patch
+2867659a46fb059cae0f261d058a8c23 fix-issue54-1.patch
+30287d85baab9c1d98d970ee95640e24 fix-issue54-2.patch"
+sha256sums="84ce1e2496868f55de3cabc2668e68689c2ff56468fff46546418a8795a60403 dircproxy-1_2_0-BETA.tar.gz
+0a1273040bd203aaf7f40b86c4e8e893f06356aa8899b89c97c05769e60dddee fix-gcc4-issue.patch
+ca21b76c8356d821c82324aaaeff9e64e8ca6ba202f9755b1b2656de0af6d74f fix-segfault.patch
+fe6fac70a09de7afd8778d03b8357425a10a111daa154a2ddb99fd6a6f8f6a3b fix-issue54-1.patch
+9491af798003dfd1f8c0e1e2bb97366880e046418d19eee3bf6e17bcc057224f fix-issue54-2.patch"
+sha512sums="9a720823cba52b1e3670a2ef76578f952e07275d7455f7609eff7d88bcb89f8c3098e9d517266efd19f84b3adf3163a3359b4113e253bd5c5bdbb36597a333c8 dircproxy-1_2_0-BETA.tar.gz
+182c1907317e669bb9f2f410c683a8ce4682ad29b3caa07548b7e126f66b85f3e1f8ad258d5a90b017f21b5e03be1aa2480c5919be25ae40b4debb6b8740e93e fix-gcc4-issue.patch
+906556a5a64670bb25394a424be281f90018c255b0dccb21f0805724899977d4041482c584f1aeb022d6acf56d5c0ab65065123bb045a2e7eb56674026be7fb4 fix-segfault.patch
+66624cc8be5c891ccd3591397608ccdbe5b8496928ab77220214ef02a10433fe7d6b67a4abbfb36b60dd8a198581814ec2485b88778c2f1c14089d0b0246c66e fix-issue54-1.patch
+517b67297d51d4327aabb0054eb5bac1a15bf26a45091517d27998e861555e5320573f315ea4d2a719387d9a30482ebf3e58d731048f78a63ecba8b4c2664fe2 fix-issue54-2.patch"
diff --git a/community/dircproxy/fix-gcc4-issue.patch b/community/dircproxy/fix-gcc4-issue.patch
new file mode 100644
index 0000000000..a839ee8abc
--- /dev/null
+++ b/community/dircproxy/fix-gcc4-issue.patch
@@ -0,0 +1,63 @@
+From 35eee84559717e378bf11a882bea9cf0b1b95238 Mon Sep 17 00:00:00 2001
+From: fharvey <fharvey@36e7e03e-8437-11dd-8f23-d9c8888c2974>
+Date: Sun, 19 Feb 2006 16:46:06 +0000
+Subject: [PATCH] Fix GCC 4.0 issue, tanks to lewk@*.edu. Close #39 and #46
+
+---
+ src/dcc_net.c | 3 ++-
+ src/irc_server.c | 6 ++++--
+ src/net.c | 3 +--
+ 3 files changed, 7 insertions(+), 5 deletions(-)
+
+diff --git a/src/dcc_net.c b/src/dcc_net.c
+index 6b90f29..1902561 100644
+--- a/src/dcc_net.c
++++ b/src/dcc_net.c
+@@ -368,7 +368,8 @@ int dccnet_expunge_proxies(void) {
+ n = p->next;
+ _dccnet_free(p);
+
+- p = (l ? l->next : proxies) = n;
++ if (l) l->next = n; else proxies = n;
++ p = n;
+ } else {
+ l = p;
+ p = p->next;
+diff --git a/src/irc_server.c b/src/irc_server.c
+index 38f4768..4ffdfca 100644
+--- a/src/irc_server.c
++++ b/src/irc_server.c
+@@ -788,7 +788,8 @@ static int _ircserver_gotmsg(struct ircproxy *p, const char *str) {
+ free(s);
+
+ /* Was in the squelch list, so remove it and stop looking */
+- s = (l ? l->next : p->squelch_modes) = n;
++ if (l) l->next = n; else p->squelch_modes = n;
++ s = n;
+ squelch = 1;
+ break;
+ } else {
+@@ -829,7 +830,8 @@ static int _ircserver_gotmsg(struct ircproxy *p, const char *str) {
+ free(s);
+
+ /* Was in the squelch list, so remove it and stop looking */
+- s = (l ? l->next : p->squelch_modes) = n;
++ if (l) l->next = n; else p->squelch_modes = n;
++ s = n;
+ squelch = 1;
+ break;
+ } else {
+diff --git a/src/net.c b/src/net.c
+index a971fea..8147acd 100644
+--- a/src/net.c
++++ b/src/net.c
+@@ -459,8 +459,7 @@ static int _net_buffer(struct sockinfo *s, int buff, int mode,
+ return 0;
+ }
+
+- l = &(buff == SB_IN ? s->in_buff_last : s->out_buff_last);
+-
++ l = (buff == SB_IN) ? &s->in_buff_last : &s->out_buff_last;
+ /* Check whether we can just add to the existing buffer */
+ if ((mode == SM_RAW) && *l && ((*l)->mode == mode)) {
+ (*l)->data = realloc((*l)->data, (*l)->len + len);
diff --git a/community/dircproxy/fix-issue54-1.patch b/community/dircproxy/fix-issue54-1.patch
new file mode 100644
index 0000000000..b35d4e4cc3
--- /dev/null
+++ b/community/dircproxy/fix-issue54-1.patch
@@ -0,0 +1,22 @@
+From 614f50d50936e36ddc947cbec16128c35276fb69 Mon Sep 17 00:00:00 2001
+From: "francois.harvey" <francois.harvey@francoisharvey.ca>
+Date: Sun, 4 Jan 2009 23:25:40 +0000
+Subject: [PATCH] Fix for #54
+
+---
+ src/irc_server.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/irc_server.c b/src/irc_server.c
+index a694ab2..185107e 100644
+--- a/src/irc_server.c
++++ b/src/irc_server.c
+@@ -1155,7 +1155,7 @@ static int _ircserver_gotmsg(struct ircproxy *p, const char *str) {
+
+ if (!strcmp(cmsg.cmd, "ACTION")) {
+ irclog_log(p, IRC_LOG_ACTION, logdest, msg.src.orig,
+- "%s", cmsg.paramstarts[0]);
++ "%s", (cmsg.paramstarts != NULL) ? cmsg.paramstarts[0]: "none");
+
+ } else if (!strcmp(cmsg.cmd, "DCC")
+ && p->conn_class->dcc_proxy_incoming) {
diff --git a/community/dircproxy/fix-issue54-2.patch b/community/dircproxy/fix-issue54-2.patch
new file mode 100644
index 0000000000..369abc8792
--- /dev/null
+++ b/community/dircproxy/fix-issue54-2.patch
@@ -0,0 +1,22 @@
+From fe1d021c4aae19c5772e2869b68a9c6ccea976d5 Mon Sep 17 00:00:00 2001
+From: "francois.harvey" <francois.harvey@francoisharvey.ca>
+Date: Sun, 4 Jan 2009 23:27:19 +0000
+Subject: [PATCH] Fix for #54
+
+---
+ src/irc_server.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/irc_server.c b/src/irc_server.c
+index 185107e..550a1ff 100644
+--- a/src/irc_server.c
++++ b/src/irc_server.c
+@@ -1155,7 +1155,7 @@ static int _ircserver_gotmsg(struct ircproxy *p, const char *str) {
+
+ if (!strcmp(cmsg.cmd, "ACTION")) {
+ irclog_log(p, IRC_LOG_ACTION, logdest, msg.src.orig,
+- "%s", (cmsg.paramstarts != NULL) ? cmsg.paramstarts[0]: "none");
++ "%s", (cmsg.paramstarts != NULL) ? cmsg.paramstarts[0]: "");
+
+ } else if (!strcmp(cmsg.cmd, "DCC")
+ && p->conn_class->dcc_proxy_incoming) {
diff --git a/community/dircproxy/fix-segfault.patch b/community/dircproxy/fix-segfault.patch
new file mode 100644
index 0000000000..2a0bd152db
--- /dev/null
+++ b/community/dircproxy/fix-segfault.patch
@@ -0,0 +1,25 @@
+From ee9552214018abf79ec110cfb1c680776294c64e Mon Sep 17 00:00:00 2001
+From: fharvey <fharvey@36e7e03e-8437-11dd-8f23-d9c8888c2974>
+Date: Sun, 1 Oct 2006 13:55:18 +0000
+Subject: [PATCH] Fix segfault. Close #15 and #44
+
+---
+ src/irc_server.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/irc_server.c b/src/irc_server.c
+index 4ffdfca..a694ab2 100644
+--- a/src/irc_server.c
++++ b/src/irc_server.c
+@@ -587,9 +587,10 @@ static int _ircserver_gotmsg(struct ircproxy *p, const char *str) {
+ ;
+ if (strcmp(ss->str,s->str)) // this line is not already present
+ ss->next = s;
+- else
++ else {
+ free(s->str);
+ free(s);
++ }
+ } else {
+ p->serversupported = s;
+ }