aboutsummaryrefslogtreecommitdiffstats
path: root/community/dnsdist/APKBUILD
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-03-11 19:49:54 -0400
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-07 17:55:36 +0000
commita1fe28b638d097f237c6a59876c4a28079d7f220 (patch)
tree44e87c3a0b09589ede027391d7a49fccb44fbdbb /community/dnsdist/APKBUILD
parenta071890ae97aeb6012fbde94f51e219ba10cc267 (diff)
downloadaports-a1fe28b638d097f237c6a59876c4a28079d7f220.tar.bz2
aports-a1fe28b638d097f237c6a59876c4a28079d7f220.tar.xz
community/dnsdist: move from testing
Diffstat (limited to 'community/dnsdist/APKBUILD')
-rw-r--r--community/dnsdist/APKBUILD116
1 files changed, 116 insertions, 0 deletions
diff --git a/community/dnsdist/APKBUILD b/community/dnsdist/APKBUILD
new file mode 100644
index 0000000000..8f83119cd4
--- /dev/null
+++ b/community/dnsdist/APKBUILD
@@ -0,0 +1,116 @@
+# Contributor: Vince Mele <vmele@inoc.com>
+# Maintainer: Vince Mele <vmele@inoc.com>
+pkgname="dnsdist"
+pkgver="1.3.3"
+pkgrel=0
+pkgdesc="dnsdist is a highly DNS-, DoS-, and abuse-aware loadbalancer."
+url="https://dnsdist.org"
+arch="all !s390x" #limited by fstrm
+license="GPL2"
+_lua_version="5.1"
+depends="$pkgname-common !$pkgname-luajit"
+makedepends="boost-dev fstrm-dev libedit-dev libsodium-dev lua${_lua_version}-dev net-snmp-dev protobuf-dev re2-dev"
+pkgusers="dnsdist"
+pkggroups="dnsdist"
+install="$pkgname-common.pre-install"
+subpackages="$pkgname-common::noarch $pkgname-doc"
+source="https://downloads.powerdns.com/releases/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
+
+# luajit is not available for s390x
+case "$CARCH" in
+ s390x) ;;
+ *)
+ makedepends="$makedepends luajit-dev"
+ subpackages="$subpackages $pkgname-luajit"
+ ;;
+esac
+
+prepare() {
+ default_prepare
+
+ case "$subpackages" in
+ *-luajit*) cp -a "$builddir" "$builddir-jit";;
+ esac
+}
+
+_configure() {
+ local _arg="$1"
+ local _luajit
+
+ [ "$_arg" = '-jit' ] || _arg='' _luajit="lua${_lua_version}"
+
+ cd "$builddir$_arg"
+
+ ./configure \
+ --build="$CBUILD" \
+ --host="$CHOST" \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --enable-unit-tests \
+ --enable-dnscrypt \
+ --enable-dns-over-tls \
+ --enable-fstrm \
+ --enable-libsodium \
+ --enable-re2 \
+ --with-protobuf \
+ --with-boost=/usr/include \
+ --with-net-snmp \
+ --with-lua${_luajit:+=$_luajit}
+}
+
+build() {
+ cd "$builddir"
+
+ _configure
+ make
+
+ [ -d "$builddir-jit" ] || return 0
+
+ _configure -jit
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+ ./dnsdist --version
+
+ [ -d "$builddir-jit" ] || return 0
+
+ cd "$builddir-jit"
+ make check
+ ./dnsdist --version
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
+
+ mv "$pkgdir/usr/bin/$pkgname" "$pkgdir/usr/bin/$pkgname-lua"
+
+ if cd "$builddir-jit"; then
+ make -j1 DESTDIR="$pkgdir" install-exec
+ mv "$pkgdir/usr/bin/$pkgname" "$pkgdir/usr/bin/$pkgname-luajit"
+ fi
+
+ mv "$pkgdir/usr/bin/$pkgname-lua" "$pkgdir/usr/bin/$pkgname"
+}
+
+common() {
+ pkgdesc="$pkgname common files"
+ depends=""
+
+ mkdir -p "$subpkgdir"
+}
+
+luajit() {
+ pkgdesc="$pkgname with luajit bindings"
+ depends="$pkgname-common !$pkgname"
+
+ mkdir -p "$subpkgdir/usr/bin"
+ mv "$pkgdir/usr/bin/$pkgname-luajit" "$subpkgdir/usr/bin/$pkgname"
+}
+
+sha512sums="c0e3435eafc1f7bcdf41346cecf7b089cc142716f94058f9ec262d0c6ad16467e0b8bed5abc648829c597120c94f998602849ded574e75bfc1a1fb70c1b719ad dnsdist-1.3.3.tar.bz2"