aboutsummaryrefslogtreecommitdiffstats
path: root/community/dockerpy-creds
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-07-03 12:29:24 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-07-03 12:30:06 +0000
commit3f84dae6992c149e465bea1b91560e7755ba7dbf (patch)
tree86e89fd7fb0c60396ac856d33dea54b75f46a53c /community/dockerpy-creds
parent1a8cdc733f6f8b9f7e436cb8cdfba039370abb2a (diff)
downloadaports-3f84dae6992c149e465bea1b91560e7755ba7dbf.tar.bz2
aports-3f84dae6992c149e465bea1b91560e7755ba7dbf.tar.xz
community/dockerpy-creds: new aport. Its now a requirement for docker-py. Python3.6 not yet supported
Diffstat (limited to 'community/dockerpy-creds')
-rw-r--r--community/dockerpy-creds/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/dockerpy-creds/APKBUILD b/community/dockerpy-creds/APKBUILD
new file mode 100644
index 0000000000..57f30d9727
--- /dev/null
+++ b/community/dockerpy-creds/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=dockerpy-creds
+pkgver=0.2.1
+pkgrel=0
+pkgdesc="Python bindings for the docker credentials store API"
+url="https://github.com/shin-/dockerpy-creds"
+arch="noarch"
+license="APACHE"
+depends="python2 py2-six"
+makedepends="python2-dev py-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/shin-/dockerpy-creds/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="456c3fc8d0ed2fda7ec7cf9f455e7a6511e8bac84f9deb16ede0a907a3ed6538777174f8367ece656f9cf4f947d9f2cdbd971e5d7867049c3b1f4c09e2314d50 dockerpy-creds-0.2.1.tar.gz"