aboutsummaryrefslogtreecommitdiffstats
path: root/community/domoticz/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-04-19 16:42:26 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-04-19 16:42:34 +0200
commit59d3088ed11c9cc56303c89739f3ee903dc42a4a (patch)
tree24f34d8bfafb4c69c0041cdb3b2143771896dcc5 /community/domoticz/APKBUILD
parent270e41f60340a746beba1d94f729fb21386f5b1b (diff)
downloadaports-59d3088ed11c9cc56303c89739f3ee903dc42a4a.tar.bz2
aports-59d3088ed11c9cc56303c89739f3ee903dc42a4a.tar.xz
community/domoticz: upgrade to 3.4834 and move to community
Diffstat (limited to 'community/domoticz/APKBUILD')
-rw-r--r--community/domoticz/APKBUILD70
1 files changed, 70 insertions, 0 deletions
diff --git a/community/domoticz/APKBUILD b/community/domoticz/APKBUILD
new file mode 100644
index 0000000000..5cae8adda2
--- /dev/null
+++ b/community/domoticz/APKBUILD
@@ -0,0 +1,70 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=domoticz
+pkgver=3.4834
+pkgrel=0
+pkgdesc="Open source Home Automation System"
+url="http://www.domoticz.com/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev cmake openssl-dev zlib-dev curl-dev boost-dev
+ sqlite-dev lua5.2-dev mosquitto-dev libusb-compat-dev openzwave-dev"
+install="$pkgname.pre-install"
+subpackages=""
+source="domoticz-$pkgver.tar.gz::https://github.com/domoticz/domoticz/archive/$pkgver.tar.gz
+ domoticz.confd
+ domoticz.initd
+ ca371a9c66fb5bc87d942a3c6bcf72213ccd2f70.patch
+ "
+
+builddir="$srcdir/domoticz-$pkgver"
+
+build() {
+ cd "$builddir"
+ cmake \
+ -DBUILD_SHARED_LIBS=True \
+ -DUSE_STATIC_LIBSTDCXX=OFF \
+ -DOpenZWave=/usr/lib/libopenzwave.so \
+ -DUSE_STATIC_OPENZWAVE=OFF \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/var/lib/domoticz \
+ -DUSE_BUILTIN_LUA=OFF \
+ -DUSE_BUILTIN_MQTT=OFF \
+ -DUSE_BUILTIN_SQLITE=OFF \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ mkdir -p "$pkgdir"/usr/bin \
+ "$pkgdir"/usr/share/$pkgname || return 1
+ mv "$pkgdir"/var/lib/domoticz/domoticz \
+ "$pkgdir"/usr/bin/ || return 1
+ mv "$pkgdir"/var/lib/domoticz/www \
+ "$pkgdir"/usr/share/$pkgname/ || return 1
+ mv "$pkgdir"/var/lib/domoticz/Config \
+ "$pkgdir"/usr/share/$pkgname/ || return 1
+ rm -f "$pkgdir"/var/lib/domoticz/updatedomo
+ chown -R $pkgname "$pkgdir"/var/lib/domoticz || return 1
+ install -D -m755 "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname || return 1
+ install -D -m644 "$srcdir"/$pkgname.confd \
+ "$pkgdir"/etc/conf.d/$pkgname || return 1
+}
+
+md5sums="fc3c396eadca9a8b622f69d86351ac37 domoticz-3.4834.tar.gz
+e5ecebdcc238af91a89081a115530175 domoticz.confd
+c7a183cf8d3df2d0dd14380d13694847 domoticz.initd
+791bb99d93063a97e64026a27df1fbb9 ca371a9c66fb5bc87d942a3c6bcf72213ccd2f70.patch"
+sha256sums="02b4cdde8e376258aeae3d5621edf8bb6b3563c34282e50194db343fcec9c0f5 domoticz-3.4834.tar.gz
+155e9c33c5a99bb32e925c834b2530451640a8a58e39aa63e358401711d67ff3 domoticz.confd
+4701360626f3951102e8b827031d2099f241a003123bc9114237ba67b24e2845 domoticz.initd
+9ca9368d20eb5f177e1b3deccba224ee5e743fb22af0ecf0585d1da815c15572 ca371a9c66fb5bc87d942a3c6bcf72213ccd2f70.patch"
+sha512sums="3527075c905d47a8774fe60f9b717665c47937f3bf0b9ec0ab2351e3215230d0e4e28b0fd1d1f921b849884a20c57ca0e8600019fb4c4fa82b8d3a3839098f95 domoticz-3.4834.tar.gz
+724440da335f1e22c8dc181df62dac9ad2bcca98b39bff059de4be5901a93a0a8cb6864d92262092041d796ee7d3933f62cf337316d35a800bbb44f84a1709e0 domoticz.confd
+3ddbd3848cce2247a52e4673307a078717d75cb3fea2937d9f2442d94dccd0efc63120f1b0324c7091ae158cd0ec4fd36334af43bb887d45ff4a93e6a96e9bd2 domoticz.initd
+b6bdc0f578728ed25edb80c9117c1744c4ce1945eeea3ed9618937a6e81c6c3712e8de33769c71a3767a7cf9314973cf9265d3e1d4dfd8907f2b0c0bcf382671 ca371a9c66fb5bc87d942a3c6bcf72213ccd2f70.patch"