aboutsummaryrefslogtreecommitdiffstats
path: root/community/dumb-init
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 10:29:27 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 10:29:27 +0000
commit26e2293c53b3e713bc2e5911631bceae43575fdb (patch)
treea2e37c323e63ddeade08d3323d5732bd2be6c51f /community/dumb-init
parent59b0f6a7ee2319c6bc656846ab522f9b493da046 (diff)
downloadaports-26e2293c53b3e713bc2e5911631bceae43575fdb.tar.bz2
aports-26e2293c53b3e713bc2e5911631bceae43575fdb.tar.xz
community/dumb-init: moved from testing, upgrade to 1.1.3
Diffstat (limited to 'community/dumb-init')
-rw-r--r--community/dumb-init/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/dumb-init/APKBUILD b/community/dumb-init/APKBUILD
new file mode 100644
index 0000000000..7cd888ea26
--- /dev/null
+++ b/community/dumb-init/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Aaron Hurt <ahurtd@ena.com>
+# Maintainer: Aaron Hurt <ahurt@ena.com>
+pkgname=dumb-init
+pkgver=1.1.3
+pkgrel=0
+pkgdesc="A minimal init system for Linux containers"
+url="https://github.com/Yelp/dumb-init"
+arch="all"
+license="MIT"
+depends=""
+makedepends="bash"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Yelp/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ install -sD -m 755 dumb-init "$pkgdir"/usr/bin/dumb-init
+}
+
+md5sums="cc910402302810b750858e5bb2a5433e dumb-init-1.1.3.tar.gz"
+sha256sums="8654be1bf0220fef8a965cebe23b8efbfcaced032cec5db62d50ca33a16575cc dumb-init-1.1.3.tar.gz"
+sha512sums="3b5bb7b2b29d0d620c65c0734df614b937f9cd91500d7395c2eb244f3aa1ac19b97782a9f6f847bef36a47317b8d948101d020250eb735c4b96585e76e7fde47 dumb-init-1.1.3.tar.gz"