aboutsummaryrefslogtreecommitdiffstats
path: root/community/dune
diff options
context:
space:
mode:
authorPedro Filipe <pedrofilipecerqueira@outlook.com>2019-06-18 22:01:01 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-02 07:25:45 -0300
commitd24771b0f8bb61e2f001b353f3b91e5d89180d53 (patch)
tree60c64320922040d9c83d7959ffd3d560c23024d6 /community/dune
parent7f4a2195be8cd9b0977010814cd8a2a9636468f8 (diff)
downloadaports-d24771b0f8bb61e2f001b353f3b91e5d89180d53.tar.bz2
aports-d24771b0f8bb61e2f001b353f3b91e5d89180d53.tar.xz
community/dune: upgrade to 1.10.0
Diffstat (limited to 'community/dune')
-rw-r--r--community/dune/APKBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/community/dune/APKBUILD b/community/dune/APKBUILD
index 895855d879..16e73b5f9a 100644
--- a/community/dune/APKBUILD
+++ b/community/dune/APKBUILD
@@ -2,19 +2,18 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
# NOTE: Upstream is slowly renaming jbuilder to dune.
pkgname=dune
-pkgver=1.0_beta200
-_pkgver=1.0+beta20
+pkgver=1.10.0
pkgrel=0
pkgdesc="A composable build system for OCaml (formerly Jbuilder)"
url="https://github.com/ocaml/dune"
arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml abuild
license="Apache-2.0"
checkdepends="bash"
-makedepends="ocaml ocaml-findlib-dev"
+makedepends="ocaml ocaml-compiler-libs ocaml-findlib-dev"
provides="jbuilder=$pkgver-r$pkgrel"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ocaml/$pkgname/archive/$_pkgver.tar.gz"
-builddir="$srcdir/$pkgname-${_pkgver/+/-}"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ocaml/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
options="!check" # FIXME requires ocaml-menhir
build() {
@@ -39,15 +38,15 @@ package() {
"$pkgdir"/usr/share/doc/$pkgname \
"$pkgdir"/usr/share/man/man1
- # The files to install are stored in _build as symlinks;
+ # The files to install are stored in _boot as symlinks;
# dereference them.
- cd _build/install/default
+ cd _boot/install/default
cp -aL bin/jbuilder "$pkgdir"/usr/bin/
- cp -aL lib/jbuilder/* "$pkgdir"/usr/lib/ocaml/jbuilder/
- cp -aL doc/jbuilder/* "$pkgdir"/usr/share/doc/$pkgname/
+ cp -aL lib/dune/* "$pkgdir"/usr/lib/ocaml/jbuilder/
+ cp -aL doc/dune/* "$pkgdir"/usr/share/doc/$pkgname/
cp -aL man/man1/* "$pkgdir"/usr/share/man/man1/
ln -s jbuilder "$pkgdir"/usr/bin/dune
}
-sha512sums="3930af586724f86300ca595586cf8238d1b33080fe2186376a65727b9a77a81b2210ccf509d1263ae331dfcc876dc0786ef49ce0a8e709556ea07506d58124d1 dune-1.0_beta200.tar.gz"
+sha512sums="15c3f5da31ae6062e41cb9e4137b740f8b227b1e59b0f00b9b2f7705bbe517da184835be007e6bb980e3615ce2ac71de67bdda92605caee1cbc0a27f34f67a1e dune-1.10.0.tar.gz"