aboutsummaryrefslogtreecommitdiffstats
path: root/community/duo_unix
diff options
context:
space:
mode:
authorPaul Morgan <jumanjiman@gmail.com>2017-06-22 10:59:08 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-06-23 08:23:39 +0000
commit6f61db13e5d97af2c90fa582dbbe0d6bb0c70aab (patch)
tree2e989b4bd6acd784699eac52554fa93cd516ffd1 /community/duo_unix
parentb820ad148afcc432843ce1577c33b9902f7880aa (diff)
downloadaports-6f61db13e5d97af2c90fa582dbbe0d6bb0c70aab.tar.bz2
aports-6f61db13e5d97af2c90fa582dbbe0d6bb0c70aab.tar.xz
community/duo_unix: upgrade to 1.10.0
Remove libressl patch because it's in upstream duo_unix as of https://github.com/duosecurity/duo_unix/commit/c539ba7aa3ec064
Diffstat (limited to 'community/duo_unix')
-rw-r--r--community/duo_unix/APKBUILD8
-rw-r--r--community/duo_unix/libressl.patch7
2 files changed, 3 insertions, 12 deletions
diff --git a/community/duo_unix/APKBUILD b/community/duo_unix/APKBUILD
index 3be181684b..4dcc1e246f 100644
--- a/community/duo_unix/APKBUILD
+++ b/community/duo_unix/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
# Maintainer: Paul Morgan <jumanjiman@gmail.com>
pkgname=duo_unix
-pkgver=1.9.21
+pkgver=1.10.0
pkgrel=0
pkgdesc="duosecurity.com two-factor authentication"
url="https://duo.com/support/documentation/duounix"
@@ -12,8 +12,7 @@ depends_dev="libressl-dev zlib-dev"
makedepends="$depends_dev"
options="suid"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://dl.duosecurity.com/$pkgname-$pkgver.tar.gz
- libressl.patch"
+source="https://dl.duosecurity.com/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
build() {
@@ -33,5 +32,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="8caf1b9dea266662d2e221fa120be1989622828ba346f874f77090ed0f91431e250da2cfe335bc9ff0b8a6336a20458851e715342c5f90151cf4514e76b04fa9 duo_unix-1.9.21.tar.gz
-4e078c876baaedeffb4b8790f713e4bd486a71ef8a8cccade9262ea56dc7ada4ec65f467850d6d2311899b4d93afc95e21d0b585a446a3ca0a36498ada37ec67 libressl.patch"
+sha512sums="d73bcc645084e98fda755476b8e7e4dd086741b48a62efd3905757e759259a06d725471fb258e34d37d0c3d799a1c0c73eb5f651270f2e211b32273a058f9ba3 duo_unix-1.10.0.tar.gz"
diff --git a/community/duo_unix/libressl.patch b/community/duo_unix/libressl.patch
deleted file mode 100644
index 57c5f2f95d..0000000000
--- a/community/duo_unix/libressl.patch
+++ /dev/null
@@ -1,7 +0,0 @@
-diff --git a/lib/https.c b/lib/https.c
-index b64e03a..b900924 100644
---- a/lib/https.c
-+++ b/lib/https.c
-@@ -356 +356 @@ _establish_connection(struct https_request * const req,
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)