aboutsummaryrefslogtreecommitdiffstats
path: root/community/duply
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-05-08 11:03:57 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-05-08 08:04:31 -0300
commit17643e3f6d2cdef2e9bf2a81e392d1622fed9d3e (patch)
tree7bdfd8e4ee07b7973e664645f1a72647b4859514 /community/duply
parente3c2a60effef3fdd19a9c57adc29428c40beeb4d (diff)
downloadaports-17643e3f6d2cdef2e9bf2a81e392d1622fed9d3e.tar.bz2
aports-17643e3f6d2cdef2e9bf2a81e392d1622fed9d3e.tar.xz
community/duply: move from main
Diffstat (limited to 'community/duply')
-rw-r--r--community/duply/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/duply/APKBUILD b/community/duply/APKBUILD
new file mode 100644
index 0000000000..7a27f88ed5
--- /dev/null
+++ b/community/duply/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=duply
+pkgver=2.2.2
+pkgrel=1
+pkgdesc="Wrapper for duplicity"
+url="https://duply.net"
+arch="noarch"
+license="GPL-2.0-or-later"
+depends="duplicity bash"
+# no test provided upstream
+options="!check"
+makedepends="txt2man"
+subpackages="$pkgname-doc"
+source="https://netix.dl.sourceforge.net/project/ftplicity/duply%20(simple%20duplicity)/2.2.x/duply_$pkgver.tgz"
+builddir="$srcdir"/duply_$pkgver
+
+package() {
+ install -Dm755 duply \
+ "$pkgdir"/usr/bin/duply
+ mkdir -p "$pkgdir"/usr/share/man/man1
+ "$pkgdir"/usr/bin/duply txt2man > \
+ "$pkgdir"/usr/share/man/man1/duply.1
+ install -Dm644 gpl-2.0.txt \
+ "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+sha512sums="2c072f3812989d2d20f9698b5a59eebe5ca8d45eda25622b9e9903748c8fa18374f8d64e0897b7587f62a6a292b277302d15c6785c6b4dd96e127162a5dae358 duply_2.2.2.tgz"