aboutsummaryrefslogtreecommitdiffstats
path: root/community/dynamips
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-07-01 17:43:44 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-07-01 17:43:44 +0000
commit738f3de16046a71713a0e1b8eec1fce8d58f337a (patch)
tree74f2e6dde5231a17c7e3b7308c340a2486321cde /community/dynamips
parent91b37b0fd008b2041564db43248013d472e04c02 (diff)
downloadaports-738f3de16046a71713a0e1b8eec1fce8d58f337a.tar.bz2
aports-738f3de16046a71713a0e1b8eec1fce8d58f337a.tar.xz
community/dynamips: Comment out DYNAMIPS_FLAGS to respect CFLAGS
Diffstat (limited to 'community/dynamips')
-rw-r--r--community/dynamips/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/community/dynamips/APKBUILD b/community/dynamips/APKBUILD
index 930f72107c..77a7c37cc2 100644
--- a/community/dynamips/APKBUILD
+++ b/community/dynamips/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=dynamips
pkgver=0.2.16
-pkgrel=1
+pkgrel=2
pkgdesc="Cisco router emulator"
url="https://github.com/GNS3/dynamips"
arch="all"
@@ -13,6 +13,12 @@ source="${pkgname}-${pkgver}.tar.gz::https://github.com/GNS3/${pkgname}/archive/
s390x-support.patch"
builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$builddir"
+ sed -e "s:^set ( DYNAMIPS_FLAGS:#&:" -i cmake/dependencies.cmake
+ default_prepare
+}
+
build() {
cd "$builddir"
if test $CARCH == x86_64; then