aboutsummaryrefslogtreecommitdiffstats
path: root/community/editorconfig
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-17 19:52:15 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-17 19:55:25 +0100
commit1a3cb52e95c7c248356d4bd71c7ea465366d3c11 (patch)
tree4fd4734b37b68fa6a709260f8a8d082f2818f0e8 /community/editorconfig
parent4326aa5263b82679752aa3dfecd4288835b1c159 (diff)
downloadaports-1a3cb52e95c7c248356d4bd71c7ea465366d3c11.tar.bz2
aports-1a3cb52e95c7c248356d4bd71c7ea465366d3c11.tar.xz
community/editorconfig: modernize abuild, clarify license
Diffstat (limited to 'community/editorconfig')
-rw-r--r--community/editorconfig/APKBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/community/editorconfig/APKBUILD b/community/editorconfig/APKBUILD
index 4a87e1819d..ed53ca5094 100644
--- a/community/editorconfig/APKBUILD
+++ b/community/editorconfig/APKBUILD
@@ -7,8 +7,7 @@ pkgrel=0
pkgdesc="EditorConfig core library written in C (for use by plugins supporting EditorConfig parsing)"
url="https://github.com/editorconfig/editorconfig-core-c"
arch="all"
-license="BSD" # "Simplified" http://opensource.org/licenses/BSD-2-Clause
-depends=""
+license="BSD-2-Clause"
makedepends="cmake doxygen pcre-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/editorconfig/$_pkgname/archive/v$pkgver.tar.gz"
@@ -21,19 +20,18 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DINI_ALLOW_MULTILINE=1 \
- || return 1
- make || return 1
+ -DINI_ALLOW_MULTILINE=1
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make install DESTDIR="$pkgdir"
# Remove symlink to editorconfig-$pkgver.
- rm -f "$pkgdir/usr/bin/$pkgname" || return 1
- mv -f "$pkgdir/usr/bin/$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname" || return 1
+ rm -f "$pkgdir/usr/bin/$pkgname"
+ mv -f "$pkgdir/usr/bin/$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname"
}
sha512sums="6ab3e4f7f95c83c0781064ca15bb70394bb947f9d4cd1348224f02e25c65021d14439b913775d7cfafb93476158799c34438fa548adf3c7ec6dbfd6f1052a046 editorconfig-0.12.2.tar.gz"