aboutsummaryrefslogtreecommitdiffstats
path: root/community/esh
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-18 01:19:33 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-18 01:19:33 +0100
commit1bd66ca970e1300ec27a4868a11ce5e22e93681f (patch)
tree3855dee5e9176830597cfe31683e3162a46ff83d /community/esh
parent48f2d12034a65697996f514aaf2b4b82456c53ea (diff)
downloadaports-1bd66ca970e1300ec27a4868a11ce5e22e93681f.tar.bz2
aports-1bd66ca970e1300ec27a4868a11ce5e22e93681f.tar.xz
community/esh: move from testing
Diffstat (limited to 'community/esh')
-rw-r--r--community/esh/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/esh/APKBUILD b/community/esh/APKBUILD
new file mode 100644
index 0000000000..5a31575971
--- /dev/null
+++ b/community/esh/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=esh
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Simple template system based on shell"
+url="https://github.com/jirutka/esh"
+arch="noarch"
+license="MIT"
+checkdepends="asciidoctor"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" prefix=/usr install
+}
+
+sha512sums="79b9e66f7991f7e4d64557367a8fec5698c2efc9454bab644206fc14aed6b829973a2d475d6117c34a2ed9f86472075abbb49eaef04e88d719579a29f90449b8 esh-0.1.0.tar.gz"