aboutsummaryrefslogtreecommitdiffstats
path: root/community/etckeeper/APKBUILD
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2017-08-06 11:26:38 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-08-28 07:15:08 +0000
commitbcf6059ec23ab4ff2d600c8669a5a81c24ee74b4 (patch)
tree3f92548d945de504cf49e5d6c3543721305c1a33 /community/etckeeper/APKBUILD
parent93364931ad25e79c2137579cfe61730460695beb (diff)
downloadaports-bcf6059ec23ab4ff2d600c8669a5a81c24ee74b4.tar.bz2
aports-bcf6059ec23ab4ff2d600c8669a5a81c24ee74b4.tar.xz
community/etckeeper: move from testing
Diffstat (limited to 'community/etckeeper/APKBUILD')
-rw-r--r--community/etckeeper/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/community/etckeeper/APKBUILD b/community/etckeeper/APKBUILD
new file mode 100644
index 0000000000..39d2efb368
--- /dev/null
+++ b/community/etckeeper/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
+# Maintainer: Henrik Riomar <henrik.riomar@gmail.com>
+
+pkgname=etckeeper
+pkgver=1.18.7
+pkgrel=1
+pkgdesc="Store /etc in git."
+url="http://etckeeper.branchable.com"
+arch="noarch"
+license="GPL2"
+checkdepends="bats fakeroot"
+depends="findutils git"
+subpackages="$pkgname-doc"
+options="!checkroot"
+install="$pkgname.post-install $pkgname.pre-deinstall"
+source="$pkgname-$pkgver.tar.gz::https://git.joeyh.name/index.cgi/$pkgname.git/snapshot/$pkgname-$pkgver.tar.gz
+ apk-commit_hook
+ 0001-Work-around-git-commit-s-lack-of-robustness-by-provi.patch
+ "
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ sed -i 's|^PYTHON=python$|PYTHON=/bin/false|' Makefile
+ sed -i 's/_PACKAGE_MANAGER=.*/_PACKAGE_MANAGER=apk/' etckeeper.conf
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+
+ make install DESTDIR="$pkgdir"
+ rm -rf "$pkgdir"/lib/systemd
+ rmdir "$pkgdir"/lib/
+ rm -rf "$pkgdir"/etc/apt
+
+ install -m755 -D "$builddir"/debian/cron.daily \
+ "$pkgdir"/etc/periodic/daily/"$pkgname"
+
+ install -m755 -D "$srcdir"/apk-commit_hook \
+ "$pkgdir"/etc/apk/commit_hooks.d/"$pkgname"
+}
+
+sha512sums="44b8f66b95663da1370943128bb5673e57bd7b9df7e727c93baea5dfc79852ebba9d0834827fed19722668849d3ed18b045db5cb42135e198576a2b839523d1a etckeeper-1.18.7.tar.gz
+2b1a29d31b6e7cf4ddb05de9b5e088b5747c2abfb2d63f9bddd25f4b7dc8503d457df7fd644afe5bd6fea6a5285a111a47c0489d24378b483c1e026cc11c6bf7 apk-commit_hook
+d4aa516f7b35c2eddd5c534391fd6363429633aea3b4b2e8e46b1fe192986c79f91bf9e3e808992ce524ffc3ac96cc3952d1a1e7c3b355b7f97ffa9badc8b8d0 0001-Work-around-git-commit-s-lack-of-robustness-by-provi.patch"