aboutsummaryrefslogtreecommitdiffstats
path: root/community/evtest
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-08-20 18:52:00 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-08-20 18:52:00 +0000
commitc37b72b6f14cab1a516834564f7bf2fba1a6fd0c (patch)
tree24b5f8bbdb9415a57535af9c50a99ced12addd1e /community/evtest
parent1b3fceef67be933ff313e0749bdf33b00e00df9e (diff)
downloadaports-c37b72b6f14cab1a516834564f7bf2fba1a6fd0c.tar.bz2
aports-c37b72b6f14cab1a516834564f7bf2fba1a6fd0c.tar.xz
community/evtest: fix patch for ppc64le
The patch unconditionally includes sys/limits.h to make PATH_MAX available. This header does not exist on most arches, so only include it if PATH_MAX is missing.
Diffstat (limited to 'community/evtest')
-rw-r--r--community/evtest/APKBUILD2
-rw-r--r--community/evtest/fix-ppc64le-musl.patch4
2 files changed, 4 insertions, 2 deletions
diff --git a/community/evtest/APKBUILD b/community/evtest/APKBUILD
index 8ea3a1d3ff..14486497cf 100644
--- a/community/evtest/APKBUILD
+++ b/community/evtest/APKBUILD
@@ -31,4 +31,4 @@ package() {
}
sha512sums="94f9ff2642abbd0393d7583edd10f83487a1985963bf3186a0c957bf1d56cef30501bb38ac4df0312eab59f633a606e25638a09e43dc6f3bc31f49aa3c7cec52 evtest-1.34.tar.bz2
-d436fc203af62d8463c60517dd9d75a866af62db5d074569621d421dd343d2acbf880735fec8cd3d3f2e8f3f97c25c2c8738d31448d78ffb275930ec299ba0a5 fix-ppc64le-musl.patch"
+da2d7f44235e270e19b352c04e2d53a17839bdc93d942f7481c6162037e2f71d714dde9193643498641a2e941da69c2b2b8cb005f2951d4e584fb4796c57412b fix-ppc64le-musl.patch"
diff --git a/community/evtest/fix-ppc64le-musl.patch b/community/evtest/fix-ppc64le-musl.patch
index c551fa4484..74216fc96b 100644
--- a/community/evtest/fix-ppc64le-musl.patch
+++ b/community/evtest/fix-ppc64le-musl.patch
@@ -2,11 +2,13 @@ diff --git a/evtest.c b/evtest.c
index 37d4f85..018d1ac 100644
--- a/evtest.c
+++ b/evtest.c
-@@ -59,6 +59,7 @@
+@@ -59,6 +59,9 @@
#include <sys/time.h>
#include <sys/types.h>
#include <unistd.h>
++#ifndef PATH_MAX
+#include <sys/limits.h> /* for PATH_MAX */
++#endif
#define BITS_PER_LONG (sizeof(long) * 8)
#define NBITS(x) ((((x)-1)/BITS_PER_LONG)+1)