aboutsummaryrefslogtreecommitdiffstats
path: root/community/filezilla/APKBUILD
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2020-05-04 18:20:58 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2020-05-04 18:44:40 +0000
commitcaa3d9e18fbd20fc6a8ad85f9428bc3daff335e9 (patch)
treec4ac11abf61b6c1a775e9918867476650bd884d6 /community/filezilla/APKBUILD
parentb244804c35a8cc17470ee3e995fb651682ab0063 (diff)
downloadaports-caa3d9e18fbd20fc6a8ad85f9428bc3daff335e9.tar.bz2
aports-caa3d9e18fbd20fc6a8ad85f9428bc3daff335e9.tar.xz
community/filezilla: include assert.h
Files in engine/ refer to assert, but `assert.h` is not included for some reason. Passing `-include assert.h` via `CXXFLAGS` fixes this.
Diffstat (limited to 'community/filezilla/APKBUILD')
-rw-r--r--community/filezilla/APKBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/community/filezilla/APKBUILD b/community/filezilla/APKBUILD
index f697d5dc91..829a3e3b45 100644
--- a/community/filezilla/APKBUILD
+++ b/community/filezilla/APKBUILD
@@ -12,6 +12,7 @@ subpackages="$pkgname-doc $pkgname-lang"
source="https://download.filezilla-project.org/client/FileZilla_${pkgver}_src.tar.bz2"
build() {
+ export CXXFLAGS="$CXXFLAGS -include assert.h"
./configure \
--prefix=/usr \
--sysconfdir=/etc \