aboutsummaryrefslogtreecommitdiffstats
path: root/community/firefox-esr
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2017-04-21 19:22:22 -0400
committerJakub Jirutka <jakub@jirutka.cz>2017-04-22 01:36:29 +0200
commit6ff0c2d5d7852501d07fc15ca9baf8f613a04893 (patch)
tree119b03dffba67311b2b1e4294a424b026b13cf4f /community/firefox-esr
parent53485b87fc9f7f927b90f609c43ff4e43171ee90 (diff)
downloadaports-6ff0c2d5d7852501d07fc15ca9baf8f613a04893.tar.bz2
aports-6ff0c2d5d7852501d07fc15ca9baf8f613a04893.tar.xz
community/firefox-esr: fix build on s390x
('Error while running startup cache precompilation') at resource://gre/modules/addons/XPIProviderUtils.js Previously this error was mitigated by lowering optimization level to -O1 on s390x but no more with new esr release.
Diffstat (limited to 'community/firefox-esr')
-rw-r--r--community/firefox-esr/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/community/firefox-esr/APKBUILD b/community/firefox-esr/APKBUILD
index b5d4253d7a..6488145cc4 100644
--- a/community/firefox-esr/APKBUILD
+++ b/community/firefox-esr/APKBUILD
@@ -105,6 +105,9 @@ build() {
# set rpath so linker finds the libs
export LDFLAGS="$LDFLAGS -Wl,-rpath,${_mozappdir}"
+ local extra_flags=""
+ [ "$CARCH" = "s390x" ] && extra_flags="--disable-startupcache"
+
../configure \
--prefix=/usr \
\
@@ -141,7 +144,7 @@ build() {
--with-system-pixman \
--with-system-png \
--with-system-zlib \
- || return 1
+ $extra_flags
make || return 1
# paxmark outside fakeroot