aboutsummaryrefslogtreecommitdiffstats
path: root/community/firefox-esr
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-09-07 14:28:50 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-09-07 14:29:19 +0200
commit800379c699bf38a8c193a9889fff85f69528d8e2 (patch)
tree90fb36702674c48be1d3615834ce1d380b2fe8f2 /community/firefox-esr
parent156a0f4d2123722c470d3f09e5d693de3bfae63c (diff)
downloadaports-800379c699bf38a8c193a9889fff85f69528d8e2.tar.bz2
aports-800379c699bf38a8c193a9889fff85f69528d8e2.tar.xz
community/firefox-esr: fix build with gcc6
Diffstat (limited to 'community/firefox-esr')
-rw-r--r--community/firefox-esr/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/firefox-esr/APKBUILD b/community/firefox-esr/APKBUILD
index d2298af888..643106a7dd 100644
--- a/community/firefox-esr/APKBUILD
+++ b/community/firefox-esr/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox-esr
pkgver=45.3.0
_pkgver=$pkgver
_xulver=$pkgver
-pkgrel=0
+pkgrel=1
pkgdesc="Firefox web browser"
url="https://www.mozilla.org/en-US/firefox/organizations/faq/"
arch="all"
@@ -102,7 +102,7 @@ build() {
# mozilla's buildsystem is on drugs
export CFLAGS="$(echo $CFLAGS | sed -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')"
- export CXXFLAGS="$CFLAGS"
+ export CXXFLAGS="$CFLAGS -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
export SHELL=/bin/sh
# set rpath so linker finds the libs