aboutsummaryrefslogtreecommitdiffstats
path: root/community/flatbuffers
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-12 22:32:41 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-12 22:32:41 -0300
commit76036a75b842e0a168e8ca9b43fa96242b219abf (patch)
tree977d2fac1e472d447d616b4143184fe57de8b738 /community/flatbuffers
parent62ce2e40005b74ff3122614694f7bb64f8037a45 (diff)
downloadaports-76036a75b842e0a168e8ca9b43fa96242b219abf.tar.bz2
aports-76036a75b842e0a168e8ca9b43fa96242b219abf.tar.xz
community/flatbuffers: upgrade to 1.12.0
Diffstat (limited to 'community/flatbuffers')
-rw-r--r--community/flatbuffers/0001-Add-detection-of-strtoull_l-function.patch38
-rw-r--r--community/flatbuffers/APKBUILD11
2 files changed, 5 insertions, 44 deletions
diff --git a/community/flatbuffers/0001-Add-detection-of-strtoull_l-function.patch b/community/flatbuffers/0001-Add-detection-of-strtoull_l-function.patch
deleted file mode 100644
index f3e82101bb..0000000000
--- a/community/flatbuffers/0001-Add-detection-of-strtoull_l-function.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From bff7ffbc5130cd46caf33b76b4bb0593fcd15066 Mon Sep 17 00:00:00 2001
-From: Vladimir Glavnyy <31897320+vglavnyy@users.noreply.github.com>
-Date: Fri, 10 May 2019 00:15:29 +0700
-Subject: [PATCH] Add detection of strtoull_l function (#5333) (#5337)
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Retrieved from:
-https://github.com/google/flatbuffers/commit/bff7ffbc5130cd46caf33b76b4bb0593fcd15066]
----
- CMakeLists.txt | 12 +++++++++---
- 1 file changed, 9 insertions(+), 3 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 0640c37b5..30be238fe 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -42,12 +42,18 @@ if(DEFINED FLATBUFFERS_MAX_PARSING_DEPTH)
- message(STATUS "FLATBUFFERS_MAX_PARSING_DEPTH: ${FLATBUFFERS_MAX_PARSING_DEPTH}")
- endif()
-
--# Auto-detect locale-narrow 'strtod_l' function.
-+# Auto-detect locale-narrow 'strtod_l' and 'strtoull_l' functions.
- if(NOT DEFINED FLATBUFFERS_LOCALE_INDEPENDENT)
-+ set(FLATBUFFERS_LOCALE_INDEPENDENT 0)
- if(MSVC)
-- check_cxx_symbol_exists(_strtof_l stdlib.h FLATBUFFERS_LOCALE_INDEPENDENT)
-+ check_cxx_symbol_exists(_strtof_l stdlib.h FLATBUFFERS_HAS_STRTOF_L)
-+ check_cxx_symbol_exists(_strtoui64_l stdlib.h FLATBUFFERS_HAS_STRTOULL_L)
- else()
-- check_cxx_symbol_exists(strtof_l stdlib.h FLATBUFFERS_LOCALE_INDEPENDENT)
-+ check_cxx_symbol_exists(strtof_l stdlib.h FLATBUFFERS_HAS_STRTOF_L)
-+ check_cxx_symbol_exists(strtoull_l stdlib.h FLATBUFFERS_HAS_STRTOULL_L)
-+ endif()
-+ if(FLATBUFFERS_HAS_STRTOF_L AND FLATBUFFERS_HAS_STRTOULL_L)
-+ set(FLATBUFFERS_LOCALE_INDEPENDENT 1)
- endif()
- endif()
- add_definitions(-DFLATBUFFERS_LOCALE_INDEPENDENT=$<BOOL:${FLATBUFFERS_LOCALE_INDEPENDENT}>)
diff --git a/community/flatbuffers/APKBUILD b/community/flatbuffers/APKBUILD
index c11a709510..29eede2f20 100644
--- a/community/flatbuffers/APKBUILD
+++ b/community/flatbuffers/APKBUILD
@@ -1,15 +1,15 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=flatbuffers
-pkgver=1.11.0
-pkgrel=1
+pkgver=1.12.0
+pkgrel=0
pkgdesc="Memory Efficient Serialization Library"
url="https://google.github.io/flatbuffers/"
arch="all !s390x"
license="Apache-2.0"
makedepends="cmake"
subpackages="$pkgname-dev"
-source="flatbuffers-$pkgver.tar.gz::https://github.com/google/flatbuffers/archive/v$pkgver.tar.gz
- 0001-Add-detection-of-strtoull_l-function.patch"
+source="flatbuffers-$pkgver.tar.gz::https://github.com/google/flatbuffers/archive/v$pkgver.tar.gz"
build() {
cmake -B build . \
@@ -30,5 +30,4 @@ package() {
"$pkgdir"/usr/bin/flatc
}
-sha512sums="cbb2e1e6885255cc950e2fa8248b56a8bc2c6e52f6fc7ed9066e6ae5a1d53f1263594b83f4b944a672cf9d0e1e800e51ce7fa423eff45abf5056269879c286fe flatbuffers-1.11.0.tar.gz
-3720593d25fb5769cab5bcf3d0e55709545de04ccc783c7cd7cac8aa99d4e861ccb6d1123073b875f75b98e45ebb8151d9b56df855bae7f28f55cbf4bc36c0b8 0001-Add-detection-of-strtoull_l-function.patch"
+sha512sums="8a0b88d739fa4694a69d3630140fe89fdd70d50bba4dadd1758d9aa2920cda16700bcafb8d89fe2a09ac907d3f378240c3cb4abc7106318136799836aba4b063 flatbuffers-1.12.0.tar.gz"