aboutsummaryrefslogtreecommitdiffstats
path: root/community/fortune
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-06-27 10:17:05 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-07-04 11:42:28 +0200
commit2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd (patch)
tree97c60fb3221dfe78cd7ccfda5db6125c81d5f676 /community/fortune
parent00e8ff605f1c4f6386596f35f2a5287ff9b8bc55 (diff)
downloadaports-2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd.tar.bz2
aports-2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd.tar.xz
testing/[various]: move packages to community
Moves the packages listed below from the testing to the community repository after successfully testing of said packages. asciinema at calcurse cmus compton cpio dvd+rw-tools fortune fvwm geary h2o heirloom-mailx leafpad nedit nmh rover tor torsocks urlview vdesk w3m wbar xcalc xclock xeyes xkill
Diffstat (limited to 'community/fortune')
-rw-r--r--community/fortune/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/fortune/APKBUILD b/community/fortune/APKBUILD
new file mode 100644
index 0000000000..c2738d8e0e
--- /dev/null
+++ b/community/fortune/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Andrew Hills <ahills@ednos.net>
+# Maintainer: Andrew Hills <ahills@ednos.net>
+pkgname=fortune
+pkgver=0.1
+pkgrel=0
+pkgdesc="Fortune cookie program ported from OpenBSD"
+url="https://github.com/ahills/fortune"
+arch="x86 x86_64"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libbsd-dev"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ cd "$_builddir"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+md5sums="a3549f7cb08891ba18776befe2dd24e3 fortune-0.1.tar.gz"
+sha256sums="5d593c8a25388b918e0f54486c6d9f9bbeb7841f825cdcc6da433153a92573a1 fortune-0.1.tar.gz"
+sha512sums="11c883aef8fafea6237fcd1b45fbbb169d6996a253f1def720dd9379c4bfe1bad050789c6e89eb7f1960abde54fe04d85fd13148bd0af8528de630611c0e6e48 fortune-0.1.tar.gz"