aboutsummaryrefslogtreecommitdiffstats
path: root/community/frotz
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-08 15:33:13 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-08 19:23:02 +0000
commit10baa708c1a46dcb1ff0498fde0e0340dcbce52b (patch)
tree520cb712c831f25e0b8e03f12505acc98b35d5b5 /community/frotz
parent9e4b90f13c14923915c0536aaca62229f707d753 (diff)
downloadaports-10baa708c1a46dcb1ff0498fde0e0340dcbce52b.tar.bz2
aports-10baa708c1a46dcb1ff0498fde0e0340dcbce52b.tar.xz
community/frotz: move from main
Diffstat (limited to 'community/frotz')
-rw-r--r--community/frotz/APKBUILD29
-rw-r--r--community/frotz/Makefile.patch49
2 files changed, 78 insertions, 0 deletions
diff --git a/community/frotz/APKBUILD b/community/frotz/APKBUILD
new file mode 100644
index 0000000000..84ef7be19c
--- /dev/null
+++ b/community/frotz/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=frotz
+pkgver=2.44
+pkgrel=1
+pkgdesc="Portable Z-Machine Interpreter"
+url="http://frotz.sourceforge.net/"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="ncurses-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/DavidGriffith/frotz/archive/$pkgver.tar.gz
+ Makefile.patch
+ "
+
+build() {
+ make
+}
+
+package() {
+ strip $pkgname
+ install -m755 -d "$pkgdir/usr/bin"
+ install -m755 -d "$pkgdir/usr/share/man/man6"
+ install -m755 $pkgname "$pkgdir/usr/bin/"
+ install -m644 doc/$pkgname.6 $pkgdir/usr/share/man/man6/$pkgname.6
+}
+
+sha512sums="20b2c8948f093463c53498b322230881aa1ad9c8fd68a338b4f5c4803ab28007fc8ba63f6d20f2b4d440fd04138709b9f4f103c9f8a71788e80156ccdff9ce1f frotz-2.44.tar.gz
+50bd0db62eb09bb316dbab106d2bba0ad389e151fefbc587dbd15faf238b559276ce9d603333d5da8760623d014e2587609b96401e616f22062cb0a6aaa2f346 Makefile.patch"
diff --git a/community/frotz/Makefile.patch b/community/frotz/Makefile.patch
new file mode 100644
index 0000000000..ead06f88d0
--- /dev/null
+++ b/community/frotz/Makefile.patch
@@ -0,0 +1,49 @@
+--- src/frotz-2.43d/Makefile 2012-01-03 08:32:58.000000000 +0000
++++ ../Makefile 2014-12-01 13:08:50.390040011 +0000
+@@ -14,19 +14,19 @@
+ #-malign-jumps=2
+
+ # Define where you want Frotz installed. Usually this is /usr/local
+-PREFIX = /usr/local
++PREFIX = /usr
+
+-MAN_PREFIX = $(PREFIX)
+-#MAN_PREFIX = /usr/local/share
++#MAN_PREFIX = $(PREFIX)
++MAN_PREFIX = /usr/share
+
+-CONFIG_DIR = $(PREFIX)/etc
+-#CONFIG_DIR = /etc
++#CONFIG_DIR = $(PREFIX)/etc
++CONFIG_DIR = /etc
+
+ # Define where you want Frotz to look for frotz.conf.
+ #
+-CONFIG_DIR = /usr/local/etc
+-#CONFIG_DIR = /etc
+-#CONFIG_DIR = /usr/pkg/etc
++#CONFIG_DIR = /usr/local/etc
++#CONFIG_DIR = /etc
++#CONFIG_DIR = /usr/pkg/etc
+ #CONFIG_DIR =
+
+ # Uncomment this if you want color support. Most, but not all curses
+@@ -73,15 +73,15 @@
+ # curses library won't work, comment out the first option and uncomment
+ # the second.
+ #
+-CURSES = -lcurses
+-#CURSES = -lncurses
++#CURSES = -lcurses
++CURSES = -lncurses
+
+ # Uncomment this if your need to use ncurses instead of the
+ # vendor-supplied curses library. This just tells the compile process
+ # which header to include, so don't worry if ncurses is all you have
+ # (like on Linux). You'll be fine.
+ #
+-#CURSES_DEF = -DUSE_NCURSES_H
++CURSES_DEF = -DUSE_NCURSES_H
+
+ # Uncomment this if you're compiling Unix Frotz on a machine that lacks
+ # the memmove(3) system call. If you don't know what this means, leave it