aboutsummaryrefslogtreecommitdiffstats
path: root/community/fstrm
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-03-12 20:22:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-03-12 20:24:20 +0000
commit35fbbb063e01c961850196a4a789e5d30a4cdc10 (patch)
tree765ab378bdc598ccd8da434c33de4e99a39229d4 /community/fstrm
parentf07a49721b1899daf3946af4168524cdabfc61ce (diff)
downloadaports-35fbbb063e01c961850196a4a789e5d30a4cdc10.tar.bz2
aports-35fbbb063e01c961850196a4a789e5d30a4cdc10.tar.xz
community/fstrm: reduce number of testruns
it appears that tests times out on s390x. reduce number of messages to 10k. see also https://github.com/farsightsec/fstrm/issues/58
Diffstat (limited to 'community/fstrm')
-rw-r--r--community/fstrm/APKBUILD7
-rw-r--r--community/fstrm/reduce-testruns.patch39
2 files changed, 43 insertions, 3 deletions
diff --git a/community/fstrm/APKBUILD b/community/fstrm/APKBUILD
index 3fb1a1095a..4a1ba80b73 100644
--- a/community/fstrm/APKBUILD
+++ b/community/fstrm/APKBUILD
@@ -14,7 +14,8 @@ depends_dev="libevent-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="https://dl.farsightsecurity.com/dist/$pkgname/$pkgname-$pkgver.tar.gz"
+source="https://dl.farsightsecurity.com/dist/$pkgname/$pkgname-$pkgver.tar.gz
+ reduce-testruns.patch"
build() {
cd "$builddir"
@@ -40,5 +41,5 @@ package() {
make -j1 DESTDIR="$pkgdir" install
}
-sha256sums="10ee7792a86face1d2271dc591652ab8c7af6976883887c69fdb11f10da135fc fstrm-0.5.0.tar.gz"
-sha512sums="cc60d8974d73d4f5327c46fe642151c88cf8d670ac9bb5db6cb5990b6c0995a0e09c9ae1a6c86ecbfd35fe03664b5402becd68bc6e81e83e9f4b84668d866f25 fstrm-0.5.0.tar.gz"
+sha512sums="cc60d8974d73d4f5327c46fe642151c88cf8d670ac9bb5db6cb5990b6c0995a0e09c9ae1a6c86ecbfd35fe03664b5402becd68bc6e81e83e9f4b84668d866f25 fstrm-0.5.0.tar.gz
+1c687ee7741fb20a571c3d7d3fb9a1cf09709d83d66d788eb09835750ee2313aa565f74d35a9cdece2154e1b8c41c68b268ca8f5bc33f8d14550ebe46880d550 reduce-testruns.patch"
diff --git a/community/fstrm/reduce-testruns.patch b/community/fstrm/reduce-testruns.patch
new file mode 100644
index 0000000000..2566c17851
--- /dev/null
+++ b/community/fstrm/reduce-testruns.patch
@@ -0,0 +1,39 @@
+diff --git a/t/run_test_fstrm_io_file.sh b/t/run_test_fstrm_io_file.sh
+index 554fbe8..ee00985 100755
+--- a/t/run_test_fstrm_io_file.sh
++++ b/t/run_test_fstrm_io_file.sh
+@@ -9,7 +9,7 @@ fi
+
+ for QUEUE_MODEL in SPSC MPSC; do
+ for NUM_THREADS in 1 4 16; do
+- for NUM_MESSAGES in 1 1000 100000; do
++ for NUM_MESSAGES in 1 1000 10000; do
+ $DIRNAME/$TNAME "$FILENAME" $QUEUE_MODEL $NUM_THREADS $NUM_MESSAGES
+ done
+ done
+diff --git a/t/run_test_fstrm_io_tcp.sh b/t/run_test_fstrm_io_tcp.sh
+index f8a14ba..c59e997 100755
+--- a/t/run_test_fstrm_io_tcp.sh
++++ b/t/run_test_fstrm_io_tcp.sh
+@@ -9,7 +9,7 @@ fi
+
+ for QUEUE_MODEL in SPSC MPSC; do
+ for NUM_THREADS in 1 4 16; do
+- for NUM_MESSAGES in 1 1000 100000; do
++ for NUM_MESSAGES in 1 1000 10000; do
+ $DIRNAME/$TNAME $SOCKADDR $QUEUE_MODEL $NUM_THREADS $NUM_MESSAGES
+ done
+ done
+diff --git a/t/run_test_fstrm_io_unix.sh b/t/run_test_fstrm_io_unix.sh
+index ac3080e..cf6ce82 100755
+--- a/t/run_test_fstrm_io_unix.sh
++++ b/t/run_test_fstrm_io_unix.sh
+@@ -9,7 +9,7 @@ fi
+
+ for QUEUE_MODEL in SPSC MPSC; do
+ for NUM_THREADS in 1 4 16; do
+- for NUM_MESSAGES in 1 1000 100000; do
++ for NUM_MESSAGES in 1 1000 10000; do
+ $DIRNAME/$TNAME "$SOCKNAME" $QUEUE_MODEL $NUM_THREADS $NUM_MESSAGES
+ done
+ done