aboutsummaryrefslogtreecommitdiffstats
path: root/community/fstrm
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-03-06 08:07:06 -0500
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-08 23:51:14 +0000
commit8a565511ac7d8271f0711d13a3a9c2ed4e59c8e2 (patch)
tree8e90f9abd5fb5dccae999816f1777e068aad6433 /community/fstrm
parent6ae077896b21e3715bc163e490e41ebd46e84fa2 (diff)
downloadaports-8a565511ac7d8271f0711d13a3a9c2ed4e59c8e2.tar.bz2
aports-8a565511ac7d8271f0711d13a3a9c2ed4e59c8e2.tar.xz
community/fstrm: move from testing
Diffstat (limited to 'community/fstrm')
-rw-r--r--community/fstrm/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/fstrm/APKBUILD b/community/fstrm/APKBUILD
new file mode 100644
index 0000000000..b3369a6bb6
--- /dev/null
+++ b/community/fstrm/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: tcely <tcely@users.noreply.github.com>
+# Maintainer:
+pkgname="fstrm"
+pkgver="0.4.0"
+pkgrel=0
+pkgdesc="Frame Streams implementation in C"
+url="https://github.com/farsightsec/fstrm"
+arch="all !s390x"
+license="Apache-2.0"
+depends=""
+depends_dev="libevent-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://dl.farsightsecurity.com/dist/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --build="$CBUILD" \
+ --host="$CHOST" \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make
+}
+
+check() {
+ cd "$builddir"
+
+ make check
+}
+
+package() {
+ cd "$builddir"
+
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+sha256sums="b20564cb2ebc7783a8383fbef5bcef5726f94baf48b83843553c9e1030b738ef fstrm-0.4.0.tar.gz"