aboutsummaryrefslogtreecommitdiffstats
path: root/community/fzf
diff options
context:
space:
mode:
authorRobert White <rjwhite2453@gmail.com>2019-10-03 08:03:44 +1000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-31 08:16:11 +0000
commitd527f562a1ae4e54febb7c7cf90b11fbb9ebdfa7 (patch)
tree4ce653033fed245628bab70230ceb693a1abef1c /community/fzf
parentdcf72e9c338ef29026e546b40a0ba9b77eb18112 (diff)
downloadaports-d527f562a1ae4e54febb7c7cf90b11fbb9ebdfa7.tar.bz2
aports-d527f562a1ae4e54febb7c7cf90b11fbb9ebdfa7.tar.xz
community/fzf: build using go instead of make
This way all architectures are supported.
Diffstat (limited to 'community/fzf')
-rw-r--r--community/fzf/APKBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/community/fzf/APKBUILD b/community/fzf/APKBUILD
index 92dd89acd1..2c91df2054 100644
--- a/community/fzf/APKBUILD
+++ b/community/fzf/APKBUILD
@@ -1,3 +1,4 @@
+# Contributor: Robert White <rjwhite2453@gmail.com>
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=fzf
@@ -5,7 +6,7 @@ pkgver=0.18.0
pkgrel=4
pkgdesc="A command-line fuzzy finder"
url="https://github.com/junegunn/fzf"
-arch="all !s390x !aarch64 !armhf !armv7"
+arch="all"
license="MIT"
makedepends="go glide bash tmux"
subpackages="
@@ -36,18 +37,21 @@ prepare() {
build() {
cd "$builddir"
- make
+ go build
}
check() {
- cd "$builddir"
- make test
+ cd "$builddir"
+ SHELL=/bin/sh GOOS= go test -v \
+ github.com/junegunn/fzf/src \
+ github.com/junegunn/fzf/src/algo \
+ github.com/junegunn/fzf/src/tui \
+ github.com/junegunn/fzf/src/util
}
package() {
cd "$builddir"
- make install # Just copies the target binary to $buildir/bin
- install -Dm0755 bin/fzf "$pkgdir"/usr/bin/fzf
+ install -Dm0755 fzf "$pkgdir"/usr/bin/fzf
install -D man/man1/fzf.1 "$pkgdir"/usr/share/man/man1/fzf.1
install -D man/man1/fzf-tmux.1 "$pkgdir"/usr/share/man/man1/fzf-tmux.1
@@ -113,6 +117,12 @@ nvim() {
install -Dm0644 doc/fzf.txt "$subpkgdir"/usr/share/nvim/runtime/doc/fzf.txt
}
+cleanup_srcdir() {
+ export GOPATH="$srcdir"
+ go clean -modcache
+ default_cleanup_srcdir
+}
+
sha512sums="70dcda693ed6706f232874550f89cfcdbce1d28360244a728dd0640a4cfbbbd0899601f42c9096197c159cde86e89d287a06905cb5d665bd09b9d01cca2cb754 fzf-0.18.0.tar.gz
dc14dea17ea585344e16eeffdc244693d97f4519676d20ec43434f6eff460d61be833399469ccb44c25c9fed296d52d424208c4a4cae5a3beecba14593cecd49 glide.yaml
5d1c0801d79a0425e1ec02c818bf440f2201841f356f32350fac06bf3ed7a7d03c0718cbeadc07143701895152f7ee19919e6e527be9e17c0df430f93d0282c9 glide.lock"