aboutsummaryrefslogtreecommitdiffstats
path: root/community/fzf
diff options
context:
space:
mode:
authorKevin Daudt <ops@ikke.info>2018-03-11 16:10:15 +0000
committerSören Tempel <soeren+git@soeren-tempel.net>2018-03-11 21:16:50 +0100
commitd5cfcd38e93d52bef507fb0dd397f11e7a5c9f40 (patch)
tree639b36876647896b520ab8807dd6c359a625c0f0 /community/fzf
parent2a0a045ee30960703a3713a73b6f3601f06e1cfa (diff)
downloadaports-d5cfcd38e93d52bef507fb0dd397f11e7a5c9f40.tar.bz2
aports-d5cfcd38e93d52bef507fb0dd397f11e7a5c9f40.tar.xz
community/fzf: disable vetting in tests
Since Go 1.10, they enabled vetting by default when running tests. This reveals issues in the thests which should be fixed upstream, but for now, disable vetting to let the tests pass again. An upstream issue[0] has been created. Untill then, apply a patch to the Makefile to disable vetting. [0]: https://github.com/junegunn/fzf/issues/1236
Diffstat (limited to 'community/fzf')
-rw-r--r--community/fzf/APKBUILD8
-rw-r--r--community/fzf/disable-vet-for-tests.patch13
2 files changed, 18 insertions, 3 deletions
diff --git a/community/fzf/APKBUILD b/community/fzf/APKBUILD
index 319bf998af..70a479d9b7 100644
--- a/community/fzf/APKBUILD
+++ b/community/fzf/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kevin Daudt <ops@ikke.info>
pkgname=fzf
pkgver="0.17.3"
-pkgrel=0
+pkgrel=1
pkgdesc="A command-line fuzzy finder"
url="https://github.com/junegunn/fzf"
arch="x86 x86_64"
@@ -10,7 +10,8 @@ license="MIT"
makedepends="go glide bash tmux"
subpackages="$pkgname-tmux::noarch $pkgname-extras::noarch"
source="$pkgname-$pkgver.tar.gz::https://github.com/junegunn/fzf/archive/$pkgver.tar.gz
- no-glide-install.patch"
+ no-glide-install.patch
+ disable-vet-for-tests.patch"
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
@@ -56,4 +57,5 @@ extras() {
}
sha512sums="2713ef7adb0dd278ac0a0c362c5cd23e7b0f1867efdfa964ad1f63f48c7f518e0cf96cc0b2571487585a0271fb0d2398edfebdbe603ec2bb42d3bd87febd2156 fzf-0.17.3.tar.gz
-daa16985079e3b55ccf5e74dde356e1e13e43865c9809e432b5d272b053f541f1eacd402f3b04957ee855fb8c0ca1820b507d08e408f55dc80004990a949874c no-glide-install.patch"
+daa16985079e3b55ccf5e74dde356e1e13e43865c9809e432b5d272b053f541f1eacd402f3b04957ee855fb8c0ca1820b507d08e408f55dc80004990a949874c no-glide-install.patch
+e58121867dbf06ce8a66ffe77b0a17a572833cc5c94ab73761f631908f8106eed9e0bd69fd0ca47127c64dda43086a4ea908b61daa2e75fa0dc7f5274a6b98cc disable-vet-for-tests.patch"
diff --git a/community/fzf/disable-vet-for-tests.patch b/community/fzf/disable-vet-for-tests.patch
new file mode 100644
index 0000000000..328b80277e
--- /dev/null
+++ b/community/fzf/disable-vet-for-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 5f68100828..123bfe9974 100644
+--- a/Makefile
++++ b/Makefile
+@@ -102,7 +102,7 @@ vendor: $(GLIDE_YAML)
+ touch $@
+
+ test: $(SOURCES) vendor
+- SHELL=/bin/sh GOOS= go test -v -tags "$(TAGS)" \
++ SHELL=/bin/sh GOOS= go test -v -tags "$(TAGS)" -vet=off \
+ github.com/junegunn/fzf/src \
+ github.com/junegunn/fzf/src/algo \
+ github.com/junegunn/fzf/src/tui \