aboutsummaryrefslogtreecommitdiffstats
path: root/community/fzf
diff options
context:
space:
mode:
authorKevin Daudt <ops@ikke.info>2018-02-18 18:56:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-02-20 18:06:04 +0000
commitf1eabed0fec2525fdd3eebf1a960bf6cdf4c4891 (patch)
treea8a906651f8ca6b4bf3698bb4076d5f5df4bb725 /community/fzf
parenteebfa4f8bfbcb08f1185537c669fa80ed519b1d7 (diff)
downloadaports-f1eabed0fec2525fdd3eebf1a960bf6cdf4c4891.tar.bz2
aports-f1eabed0fec2525fdd3eebf1a960bf6cdf4c4891.tar.xz
testing/fzf: move to community
Diffstat (limited to 'community/fzf')
-rw-r--r--community/fzf/APKBUILD51
-rw-r--r--community/fzf/no-glide-install.patch11
2 files changed, 62 insertions, 0 deletions
diff --git a/community/fzf/APKBUILD b/community/fzf/APKBUILD
new file mode 100644
index 0000000000..810fc47deb
--- /dev/null
+++ b/community/fzf/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Kevin Daudt <ops@ikke.info>
+# Maintainer: Kevin Daudt <ops@ikke.info>
+pkgname=fzf
+pkgver="0.17.3"
+pkgrel=0
+pkgdesc="A command-line fuzzy finder"
+url="https://github.com/junegunn/fzf"
+arch="x86 x86_64"
+license="MIT"
+makedepends="go glide bash tmux"
+subpackages="$pkgname-tmux::noarch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/junegunn/fzf/archive/$pkgver.tar.gz
+ no-glide-install.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+
+ export GOPATH="$startdir"
+ glide install
+}
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+
+ # Just copies the target binary to $buildir/bin
+ make install
+
+ install -Dm0755 bin/fzf "$pkgdir"/usr/bin/fzf
+}
+
+tmux() {
+ depends="tmux bash"
+ description="Helper script to start fzf in a tmux pane"
+
+ cd "$builddir"
+ install -Dm0755 bin/fzf-tmux "$subpkgdir"/usr/bin/fzf-tmux
+}
+
+sha512sums="2713ef7adb0dd278ac0a0c362c5cd23e7b0f1867efdfa964ad1f63f48c7f518e0cf96cc0b2571487585a0271fb0d2398edfebdbe603ec2bb42d3bd87febd2156 fzf-0.17.3.tar.gz
+daa16985079e3b55ccf5e74dde356e1e13e43865c9809e432b5d272b053f541f1eacd402f3b04957ee855fb8c0ca1820b507d08e408f55dc80004990a949874c no-glide-install.patch"
diff --git a/community/fzf/no-glide-install.patch b/community/fzf/no-glide-install.patch
new file mode 100644
index 0000000000..1704ee9e22
--- /dev/null
+++ b/community/fzf/no-glide-install.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -99,7 +99,7 @@
+ ln -sf $(ROOT_DIR)/vendor $(VENDOR_LINK)
+
+ vendor: $(GLIDE_YAML)
+- go get -u github.com/Masterminds/glide && $(GOPATH)/bin/glide install && touch $@
++ touch $@
+
+ test: $(SOURCES) vendor
+ SHELL=/bin/sh GOOS= go test -v -tags "$(TAGS)" \