aboutsummaryrefslogtreecommitdiffstats
path: root/community/gexiv2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-04-28 13:30:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-04-28 13:30:11 +0000
commit2d507637335ec7f7015b71b0c7305586aec7eb92 (patch)
treee4bd62462608a172ab3bed4c37d63d9804d56b82 /community/gexiv2
parent9c4b9874dc7828cf1ed3334776e977ecc1b1a903 (diff)
downloadaports-2d507637335ec7f7015b71b0c7305586aec7eb92.tar.bz2
aports-2d507637335ec7f7015b71b0c7305586aec7eb92.tar.xz
community/gexiv2: move from main
apparently only used by shotwell
Diffstat (limited to 'community/gexiv2')
-rw-r--r--community/gexiv2/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/community/gexiv2/APKBUILD b/community/gexiv2/APKBUILD
new file mode 100644
index 0000000000..8c30d1f04a
--- /dev/null
+++ b/community/gexiv2/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gexiv2
+pkgver=0.10.3
+pkgrel=1
+pkgdesc="a GObject-based wrapper around the Exiv2 library"
+url="https://wiki.gnome.org/Projects/gexiv2"
+arch="all"
+license="GPL"
+depends=
+depends_dev="glib-dev exiv2-dev"
+makedepends="exiv2-dev glib-dev libtool m4 sed"
+install=
+subpackages="$pkgname-dev"
+source="http://ftp.gnome.org/pub/gnome/sources/gexiv2/${pkgver%.*}/gexiv2-$pkgver.tar.xz"
+replaces="libgexiv2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-introspection \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="f255100a009027d4eaa0f075bb79c655 gexiv2-0.10.3.tar.xz"
+sha256sums="390cfb966197fa9f3f32200bc578d7c7f3560358c235e6419657206a362d3988 gexiv2-0.10.3.tar.xz"
+sha512sums="a258a95e3e9dddc6636430d8a2bc222b6605e5d0d122ea1b951f97568cecd04b2d3cbc522625918faf3b5a3e670b01db81a45c2c5c5d65e6eb4b4f4a2ac69e8f gexiv2-0.10.3.tar.xz"