aboutsummaryrefslogtreecommitdiffstats
path: root/community/gifsicle
diff options
context:
space:
mode:
authorMichael Koloberdin <koloberdin@gmail.com>2016-06-02 19:00:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-06-03 08:30:39 +0000
commit5b80bb088f79612ff4ea159b2d507c95c00b2662 (patch)
tree9c101f8278b167c5d5e82434c2fceaa992a779e9 /community/gifsicle
parentc6b269ca6fc716b6576e0f3c8620fe055de20bb0 (diff)
downloadaports-5b80bb088f79612ff4ea159b2d507c95c00b2662.tar.bz2
aports-5b80bb088f79612ff4ea159b2d507c95c00b2662.tar.xz
testing/gifsicle: move to community
Diffstat (limited to 'community/gifsicle')
-rw-r--r--community/gifsicle/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/gifsicle/APKBUILD b/community/gifsicle/APKBUILD
new file mode 100644
index 0000000000..516b544163
--- /dev/null
+++ b/community/gifsicle/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Isaac Dunham <ibid.ag@gmail.com>
+# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
+pkgname=gifsicle
+pkgver=1.88
+pkgrel=0
+pkgdesc="Command-line tool for making, editing, and getting information about GIF animations"
+url="http://www.lcdf.org/gifsicle/"
+arch="all"
+license="GPL2"
+depends=""
+makedepends="libx11-dev libice-dev libsm-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.lcdf.org/gifsicle/gifsicle-$pkgver.tar.gz"
+
+_builddir="$srcdir"/gifsicle-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="6b1cfb10c35b01ad877f2ae18cca4221 gifsicle-1.88.tar.gz"
+sha256sums="4585d2e683d7f68eb8fcb15504732d71d7ede48ab5963e61915201f9e68305be gifsicle-1.88.tar.gz"
+sha512sums="4a54557d2a9acb4601151f7a266156ebd317bddb1255d84df042a62be0f57bd75ad8585794bd82081701977c84781696bb06565a3aa1709e0ef04ab89fb2df91 gifsicle-1.88.tar.gz"