aboutsummaryrefslogtreecommitdiffstats
path: root/community/gitea/APKBUILD
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-06-17 21:03:34 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-23 18:51:06 -0300
commit390f9be9d840f55260068e0c35de5688daa76d1a (patch)
tree879eb58632df1c9b56c6e4acd4f0e6300756bc6d /community/gitea/APKBUILD
parenta230887ea5faea9dbe1ebdc7e6d84ad49d0800e8 (diff)
downloadaports-390f9be9d840f55260068e0c35de5688daa76d1a.tar.bz2
aports-390f9be9d840f55260068e0c35de5688daa76d1a.tar.xz
community/gitea: upgrade to 1.8.3
Diffstat (limited to 'community/gitea/APKBUILD')
-rw-r--r--community/gitea/APKBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/community/gitea/APKBUILD b/community/gitea/APKBUILD
index 43d543c5cb..7ffbf704d0 100644
--- a/community/gitea/APKBUILD
+++ b/community/gitea/APKBUILD
@@ -1,14 +1,16 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=gitea
-pkgver=1.8.2
-pkgrel=1
+pkgver=1.8.3
+pkgrel=0
pkgdesc="A self-hosted Git service written in Go"
url="https://gitea.io"
-arch="all"
+arch="all !aarch64" # https://github.com/go-gitea/gitea/issues/5324
license="MIT"
+[ "$CARCH" = x86 ] && options="!check" # git-lfs is currently not available
depends="git"
makedepends="go libcap"
+checkdepends="bash git-lfs gnupg openssh openssh-keygen sqlite"
install="$pkgname.pre-install"
pkgusers="gitea"
pkggroups="www-data"
@@ -21,14 +23,13 @@ source="${pkgname}-${pkgver}.tar.gz::https://github.com/go-gitea/$pkgname/archiv
builddir="$srcdir/src/code.gitea.io/$pkgname"
prepare() {
- mkdir -p ${builddir%/*}
- mv "$srcdir"/$pkgname-$pkgver "$builddir"/
- cd "$builddir"
+ mkdir -p ${builddir%/*}
+ mv "$srcdir"/$pkgname-$pkgver "$builddir"/
+ cd "$builddir"
default_prepare
}
build() {
- cd "$builddir"
export GOPATH="$srcdir"
export TAGS="tidb sqlite sqlite_unlock_notify"
export GITEA_VERSION="$pkgver"
@@ -36,9 +37,12 @@ build() {
make build
}
-package() {
- cd "$builddir"
+check() {
+ make test
+ timeout -s ABRT 20m make test-sqlite
+}
+package() {
for dir in $pkgname $pkgname/git $pkgname/data $pkgname/db $pkgname/custom; do
install -d -m 750 -o gitea -g www-data \
"$pkgdir"/var/lib/$dir
@@ -63,12 +67,7 @@ package() {
"$pkgdir"/etc/init.d/$pkgname
}
-check() {
- # basic check to see if the app works
- "$builddir"/$pkgname help > /dev/null
-}
-
-sha512sums="23ef63c1cea276800a19fe04b87b4baa421e1202260b4ec55614a77ee54c0bc9e5db6dad7f98791c4d902b2d4cb15f4facc4d201631cf2ef7cefd0ff996753be gitea-1.8.2.tar.gz
+sha512sums="f6019fbfc056e4c7176222ccaca1cf638bd1f52323de54fcddc618129aeb778674f6e305de60e7d17b69505ad65439445ee6b5e368afdf0a6fbace7407acb495 gitea-1.8.3.tar.gz
2497e6f2a18e3ceb65352cd220eab2c1c0893d0e731600462a60397de2b70d7c1de7db2af2769b25fe708b0822c811bb20dc797b59b9dd93efb376bea1c35796 gitea.initd
27a202006d6e8d4146659f6356eaa99437f9f596dd369e9430d64b859bc6a1ad16091eef09232aa385fe1bf8ca94bbdf31b94975068220ad10338cded384f726 gitea.ini
4eee3ab54c6e44327a1f7e68a5de320204dd46852a7eee7d6652397f03f9af72fb28455dcaec9b6498439360c6c9699ce5a7c17b9e9b0b568c6840bf1e4d13e6 allow-to-set-version.patch"