aboutsummaryrefslogtreecommitdiffstats
path: root/community/glibmm/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-27 05:41:23 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-29 15:55:31 +0000
commit3ebd23732704919040723ffba4924967f00c12d9 (patch)
tree3f7e8e0794a861a287e4ee74e2bd120a9d04c3cf /community/glibmm/APKBUILD
parent78acebec60aa49e9d8f58a78457010aec1e6325a (diff)
downloadaports-3ebd23732704919040723ffba4924967f00c12d9.tar.bz2
aports-3ebd23732704919040723ffba4924967f00c12d9.tar.xz
community/glibmm: move from main
Diffstat (limited to 'community/glibmm/APKBUILD')
-rw-r--r--community/glibmm/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/glibmm/APKBUILD b/community/glibmm/APKBUILD
new file mode 100644
index 0000000000..c67bdf1cd4
--- /dev/null
+++ b/community/glibmm/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=glibmm
+pkgver=2.64.2
+pkgrel=0
+pkgdesc="C++ wrapper for the GLib toolkit"
+url="https://www.gtkmm.org/"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="glib-dev libsigc++-dev perl"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/glibmm/${pkgver%.*}/glibmm-$pkgver.tar.xz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+dev() {
+ mkdir -p "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/glibmm-2.4 "$subpkgdir"/usr/lib/
+ default_dev
+}
+
+doc() {
+ default_doc
+ mkdir -p "$subpkgdir"/usr/share/
+ mv "$pkgdir"/usr/share/devhelp "$subpkgdir"/usr/share/
+}
+
+sha512sums="0130af9a16981a54630150db6f4b1a95458d72d650c5e4781ee97ce624ec98c600b79ebf234d212e025781453fd11d78b9e8273235ffa143397423418fe970cc glibmm-2.64.2.tar.xz"