aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-2048
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-02-28 09:36:07 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-02-29 09:44:15 +0100
commite11122cceaddaae1c4f7a6b281e1da545e7b650a (patch)
treef4b856845abc726e8bc751c88cdf716da9dca1af /community/gnome-2048
parent533d42a125a63bdf033ce5da98aeb808388f81f3 (diff)
downloadaports-e11122cceaddaae1c4f7a6b281e1da545e7b650a.tar.bz2
aports-e11122cceaddaae1c4f7a6b281e1da545e7b650a.tar.xz
community/gnome-2048: move from testing
Diffstat (limited to 'community/gnome-2048')
-rw-r--r--community/gnome-2048/APKBUILD35
-rw-r--r--community/gnome-2048/smaller-window.patch28
2 files changed, 63 insertions, 0 deletions
diff --git a/community/gnome-2048/APKBUILD b/community/gnome-2048/APKBUILD
new file mode 100644
index 0000000000..fd4f90e5c7
--- /dev/null
+++ b/community/gnome-2048/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gnome-2048
+pkgver=3.34.5
+pkgrel=1
+arch="all"
+url="https://wiki.gnome.org/Apps/2048"
+pkgdesc="Obtain the 2048 tile"
+license="GPL-3.0-or-later"
+makedepends="meson ninja itstool vala gtk+3.0-dev clutter-dev clutter-gtk-dev libgee-dev libgnome-games-support-dev"
+source="https://download.gnome.org/sources/gnome-2048/${pkgver%.*}/gnome-2048-$pkgver.tar.xz
+ smaller-window.patch"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=plain \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="78c5c41a23275a815a62e992781633b1ccbad405a9e491e9e2ebdb2fcfb7c2b989926fe3425834f0ebc529682d2df82653b0e7fbb8c3752b9454317738af8daf gnome-2048-3.34.5.tar.xz
+4d0f024d2cb3db1a5f3193a171958e81128bfec5e0a3e21d9942f508ea7a2427251eeca8904ea5088d49c9f32d327a2ee0f33e73cc1cb2df9e5fd38eb0d0b314 smaller-window.patch"
diff --git a/community/gnome-2048/smaller-window.patch b/community/gnome-2048/smaller-window.patch
new file mode 100644
index 0000000000..3fede9fe86
--- /dev/null
+++ b/community/gnome-2048/smaller-window.patch
@@ -0,0 +1,28 @@
+From 4767894600906cd55ce7e43e1a142d617b82fbd8 Mon Sep 17 00:00:00 2001
+From: Sebastian Krzyszkowiak <dos@dosowisko.net>
+Date: Thu, 12 Sep 2019 22:50:24 +0000
+Subject: [PATCH] Change the minimum window size to 350x350
+
+This allows to run the game on smaller screens, such as phones.
+---
+ src/game-window.vala | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/game-window.vala b/src/game-window.vala
+index 8ff248e..c8aef57 100644
+--- a/src/game-window.vala
++++ b/src/game-window.vala
+@@ -123,8 +123,8 @@ private class GameWindow : ApplicationWindow
+ * * window state
+ \*/
+
+- private const int WINDOW_MINIMUM_SIZE_HEIGHT = 600;
+- private const int WINDOW_MINIMUM_SIZE_WIDTH = 600;
++ private const int WINDOW_MINIMUM_SIZE_HEIGHT = 350;
++ private const int WINDOW_MINIMUM_SIZE_WIDTH = 350;
+
+ private int _window_width;
+ private int _window_height;
+--
+2.24.1
+