aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-bluetooth
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-09-15 09:59:07 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-09-15 16:28:44 +0000
commit090b7a9665f61255b854897d83f007f3e78a9a44 (patch)
treef8c3d92da3e1bb92af2d4bf4bc0c52005e7b2806 /community/gnome-bluetooth
parentbfe1a01bd47e1290ce2b3ef5c7f1e7b1e6be1683 (diff)
downloadaports-090b7a9665f61255b854897d83f007f3e78a9a44.tar.bz2
aports-090b7a9665f61255b854897d83f007f3e78a9a44.tar.xz
community/gnome-bluetooth: upgrade to 3.26.0, moderniza APKBUILD
Diffstat (limited to 'community/gnome-bluetooth')
-rw-r--r--community/gnome-bluetooth/APKBUILD55
1 files changed, 23 insertions, 32 deletions
diff --git a/community/gnome-bluetooth/APKBUILD b/community/gnome-bluetooth/APKBUILD
index 7299ffcf5a..4f55c24a2e 100644
--- a/community/gnome-bluetooth/APKBUILD
+++ b/community/gnome-bluetooth/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-bluetooth
-pkgver=3.20.1
+pkgver=3.26.0
pkgrel=0
pkgdesc="The GNOME Bluetooth Subsystem"
url="http://live.gnome.org/GnomeBluetooth"
@@ -9,47 +9,38 @@ license="GPL LGPL"
depends="hicolor-icon-theme bluez>=5"
makedepends="intltool gobject-introspection-dev libunique-dev
libnotify-dev libxi-dev libxslt py-libxml2 gnome-doc-utils
- dbus-glib-dev gtk+3.0-dev itstool eudev-dev libcanberra-dev"
-install=
+ dbus-glib-dev gtk+3.0-dev itstool eudev-dev libcanberra-dev
+ meson"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs"
-source="http://ftp.gnome.org/pub/GNOME/sources/gnome-bluetooth/${pkgver%.*}/gnome-bluetooth-$pkgver.tar.xz
- 61-gnome-bluetooth-rfkill.rules
- "
+source="http://ftp.gnome.org/pub/GNOME/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
+ 61-gnome-bluetooth-rfkill.rules"
+builddir="$srcdir"/$pkgname-$pkgver
-_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch)
- msg "Applying $i"
- patch -p1 -i "$srcdir"/$i || return 1
- ;;
- esac
- done
+ default_prepare
+ cd "$builddir"
+ mkdir -p build
}
build() {
- cd "$_builddir"
- DATADIRNAME=share ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ cd "$builddir"/build
+ meson \
--prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --disable-desktop-update \
- --disable-icon-update \
- --disable-schemas-compile \
- --enable-introspection \
- || return 1
- make
+ --buildtype=release \
+ --sysconfdir=/etc ..
+ ninja
+}
+
+check() {
+ cd "$builddir"/build
+ ninja test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" ninja install
install -m644 -D "$srcdir/61-gnome-bluetooth-rfkill.rules" \
- "$pkgdir/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules"
+ "$pkgdir/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules"
}
libs() {
@@ -59,5 +50,5 @@ libs() {
mv "$pkgdir"/usr/share/icons "$subpkgdir"/usr/share/
}
-sha512sums="945dde99c6531e369702dea22e60f5b05759d751b16b091fc67c256e949cee8153f60ac7ad616c086366a0141b263b068fad28bab4b50b84356d59b4e464d88a gnome-bluetooth-3.20.1.tar.xz
+sha512sums="db3c870392f5444d987208c73e888d5339cc6df2c59de84ed550ab0c4b3a4ff56326a197735300965ec5d10f1cab725dbb29578f0056ff4e3d4f5ba6ea1f37c5 gnome-bluetooth-3.26.0.tar.xz
80b7fd0bc3e0f82c8d2d609ffed634200e63f61d9a134445df8e8511756b7fb423d338a1d12e42b91c57243097beaa3d4662856ec0507fb19a29b6de7ee9e4de 61-gnome-bluetooth-rfkill.rules"