aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-bluetooth
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 12:11:12 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 12:11:12 +0100
commit37cca00fbe335d8c84d772d4ea3323fa204bcd71 (patch)
tree4275e1265c2a7cccc64e76beb2d5161b1818d2ca /community/gnome-bluetooth
parentf27f694e518010617995ede72357067f1f9a6525 (diff)
downloadaports-37cca00fbe335d8c84d772d4ea3323fa204bcd71.tar.bz2
aports-37cca00fbe335d8c84d772d4ea3323fa204bcd71.tar.xz
main/gnome-bluetooth: move to community
Diffstat (limited to 'community/gnome-bluetooth')
-rw-r--r--community/gnome-bluetooth/61-gnome-bluetooth-rfkill.rules11
-rw-r--r--community/gnome-bluetooth/APKBUILD70
-rw-r--r--community/gnome-bluetooth/libnotify-0.7.patch11
-rw-r--r--community/gnome-bluetooth/nogeoclue.patch138
-rw-r--r--community/gnome-bluetooth/udev-hwdb.patch46
5 files changed, 276 insertions, 0 deletions
diff --git a/community/gnome-bluetooth/61-gnome-bluetooth-rfkill.rules b/community/gnome-bluetooth/61-gnome-bluetooth-rfkill.rules
new file mode 100644
index 0000000000..a76c1e73cf
--- /dev/null
+++ b/community/gnome-bluetooth/61-gnome-bluetooth-rfkill.rules
@@ -0,0 +1,11 @@
+# Get access to /dev/rfkill for users
+# See https://bugzilla.redhat.com/show_bug.cgi?id=514798
+#
+# Updated for udev >= 154
+# http://bugs.debian.org/582188
+# https://bugzilla.redhat.com/show_bug.cgi?id=588660
+
+ENV{ACL_MANAGE}=="0", GOTO="gnome_bluetooth_end"
+ACTION!="add|change", GOTO="gnome_bluetooth_end"
+KERNEL=="rfkill", TAG+="udev-acl"
+LABEL="gnome_bluetooth_end"
diff --git a/community/gnome-bluetooth/APKBUILD b/community/gnome-bluetooth/APKBUILD
new file mode 100644
index 0000000000..d09bb6bbc2
--- /dev/null
+++ b/community/gnome-bluetooth/APKBUILD
@@ -0,0 +1,70 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnome-bluetooth
+pkgver=3.16.1
+pkgrel=1
+pkgdesc="The GNOME Bluetooth Subsystem"
+url="http://live.gnome.org/GnomeBluetooth"
+arch="all"
+license="GPL LGPL"
+depends="hicolor-icon-theme bluez>=5"
+makedepends="intltool py-gtk gobject-introspection-dev libunique-dev
+ libnotify-dev libxi-dev libxslt py-libxml2 gnome-doc-utils
+ dbus-glib-dev gtk+3.0-dev itstool eudev-dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs"
+source="http://ftp.gnome.org/pub/GNOME/sources/gnome-bluetooth/${pkgver%.*}/gnome-bluetooth-$pkgver.tar.xz
+ 61-gnome-bluetooth-rfkill.rules
+ udev-hwdb.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ DATADIRNAME=share ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-desktop-update \
+ --disable-icon-update \
+ --disable-schemas-compile \
+ --enable-introspection \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -m644 -D "$srcdir/61-gnome-bluetooth-rfkill.rules" \
+ "$pkgdir/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules"
+}
+
+libs() {
+ default_libs
+ replaces="gnome-bluetooth"
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/icons "$subpkgdir"/usr/share/
+}
+
+md5sums="de7eb807e3ae913bca53917b195d9d9f gnome-bluetooth-3.16.1.tar.xz
+9fb6c8dcb5a3de3a953bf2ef42063e6e 61-gnome-bluetooth-rfkill.rules
+89830ec8b85689843c16b0751cad2959 udev-hwdb.patch"
+sha256sums="3feb202d6780a53bc4a570eab5b0179f9351b32c1d3f28151ac2d222453ae08b gnome-bluetooth-3.16.1.tar.xz
+b8acb8ea2e7f3588575cffd8ea14ec50c8641f518f2ea899771a508b299ea474 61-gnome-bluetooth-rfkill.rules
+3d8547e186235a030bc3b3c54d1fb403a6515d405d260a4c0d6947321dca6a4d udev-hwdb.patch"
+sha512sums="811db04e1ab91585031e86cb55ee7764b0f0dfd88682afaee2e67f99af12619c540a48a3879afd8fb66e39cb35917f637b637e4b6f3ab8b8e908351426b77576 gnome-bluetooth-3.16.1.tar.xz
+80b7fd0bc3e0f82c8d2d609ffed634200e63f61d9a134445df8e8511756b7fb423d338a1d12e42b91c57243097beaa3d4662856ec0507fb19a29b6de7ee9e4de 61-gnome-bluetooth-rfkill.rules
+4b991b89a4ea3bb3997016d2028cc8239c127b2b57eea8ad9bfda1265b3370f712daf6a42868c0c357fc5cd3cded350e1a56d90f64390cb8960905329b76879c udev-hwdb.patch"
diff --git a/community/gnome-bluetooth/libnotify-0.7.patch b/community/gnome-bluetooth/libnotify-0.7.patch
new file mode 100644
index 0000000000..5265e460ef
--- /dev/null
+++ b/community/gnome-bluetooth/libnotify-0.7.patch
@@ -0,0 +1,11 @@
+--- ./applet/notify.c.orig
++++ ./applet/notify.c
+@@ -71,7 +71,7 @@
+ notify_notification_close(notify, NULL);
+ }
+
+- notify = notify_notification_new(summary, message, icon_name, NULL);
++ notify = notify_notification_new(summary, message, icon_name);
+
+ notify_notification_set_timeout(notify, timeout);
+
diff --git a/community/gnome-bluetooth/nogeoclue.patch b/community/gnome-bluetooth/nogeoclue.patch
new file mode 100644
index 0000000000..2892bee0ca
--- /dev/null
+++ b/community/gnome-bluetooth/nogeoclue.patch
@@ -0,0 +1,138 @@
+--- gnome-bluetooth-2.32.0.orig/configure
++++ gnome-bluetooth-2.32.0/configure
+@@ -638,8 +638,6 @@
+ MOBLIN_CFLAGS
+ PLUGINS_LIBS
+ PLUGINS_CFLAGS
+-GEOCLUE_LIBS
+-GEOCLUE_CFLAGS
+ COMMON_LIBS
+ COMMON_CFLAGS
+ LIBGNOMEBT_LIBS
+@@ -899,8 +897,6 @@
+ LIBGNOMEBT_LIBS
+ COMMON_CFLAGS
+ COMMON_LIBS
+-GEOCLUE_CFLAGS
+-GEOCLUE_LIBS
+ PLUGINS_CFLAGS
+ PLUGINS_LIBS
+ MOBLIN_CFLAGS
+@@ -13662,106 +13658,6 @@
+
+ fi
+
+-
+-pkg_failed=no
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for GEOCLUE" >&5
+-$as_echo_n "checking for GEOCLUE... " >&6; }
+-
+-if test -n "$GEOCLUE_CFLAGS"; then
+- pkg_cv_GEOCLUE_CFLAGS="$GEOCLUE_CFLAGS"
+- elif test -n "$PKG_CONFIG"; then
+- if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gconf-2.0
+- dbus-glib-1\""; } >&5
+- ($PKG_CONFIG --exists --print-errors "gconf-2.0
+- dbus-glib-1") 2>&5
+- ac_status=$?
+- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+- test $ac_status = 0; }; then
+- pkg_cv_GEOCLUE_CFLAGS=`$PKG_CONFIG --cflags "gconf-2.0
+- dbus-glib-1" 2>/dev/null`
+-else
+- pkg_failed=yes
+-fi
+- else
+- pkg_failed=untried
+-fi
+-if test -n "$GEOCLUE_LIBS"; then
+- pkg_cv_GEOCLUE_LIBS="$GEOCLUE_LIBS"
+- elif test -n "$PKG_CONFIG"; then
+- if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gconf-2.0
+- dbus-glib-1\""; } >&5
+- ($PKG_CONFIG --exists --print-errors "gconf-2.0
+- dbus-glib-1") 2>&5
+- ac_status=$?
+- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+- test $ac_status = 0; }; then
+- pkg_cv_GEOCLUE_LIBS=`$PKG_CONFIG --libs "gconf-2.0
+- dbus-glib-1" 2>/dev/null`
+-else
+- pkg_failed=yes
+-fi
+- else
+- pkg_failed=untried
+-fi
+-
+-
+-
+-if test $pkg_failed = yes; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-
+-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
+- _pkg_short_errors_supported=yes
+-else
+- _pkg_short_errors_supported=no
+-fi
+- if test $_pkg_short_errors_supported = yes; then
+- GEOCLUE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "gconf-2.0
+- dbus-glib-1" 2>&1`
+- else
+- GEOCLUE_PKG_ERRORS=`$PKG_CONFIG --print-errors "gconf-2.0
+- dbus-glib-1" 2>&1`
+- fi
+- # Put the nasty error message in config.log where it belongs
+- echo "$GEOCLUE_PKG_ERRORS" >&5
+-
+- as_fn_error $? "Package requirements (gconf-2.0
+- dbus-glib-1) were not met:
+-
+-$GEOCLUE_PKG_ERRORS
+-
+-Consider adjusting the PKG_CONFIG_PATH environment variable if you
+-installed software in a non-standard prefix.
+-
+-Alternatively, you may set the environment variables GEOCLUE_CFLAGS
+-and GEOCLUE_LIBS to avoid the need to call pkg-config.
+-See the pkg-config man page for more details." "$LINENO" 5
+-
+-elif test $pkg_failed = untried; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
+-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
+-as_fn_error $? "The pkg-config script could not be found or is too old. Make sure it
+-is in your PATH or set the PKG_CONFIG environment variable to the full
+-path to pkg-config.
+-
+-Alternatively, you may set the environment variables GEOCLUE_CFLAGS
+-and GEOCLUE_LIBS to avoid the need to call pkg-config.
+-See the pkg-config man page for more details.
+-
+-To get pkg-config, see <http://pkg-config.freedesktop.org/>.
+-See \`config.log' for more details" "$LINENO" 5; }
+-
+-else
+- GEOCLUE_CFLAGS=$pkg_cv_GEOCLUE_CFLAGS
+- GEOCLUE_LIBS=$pkg_cv_GEOCLUE_LIBS
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+-$as_echo "yes" >&6; }
+-
+-fi
+
+
+ pkg_failed=no
+--- gnome-bluetooth-2.32.0.orig/lib/Makefile.in
++++ gnome-bluetooth-2.32.0/lib/Makefile.in
+@@ -383,7 +383,7 @@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-SUBDIRS = plugins
++SUBDIRS =
+ EXTRA_DIST = $(am__append_2) marshal.list bluetooth-client.xml \
+ bluetooth-agent.xml obex-agent.xml gnome-bluetooth.symbols
+ BUILT_GIRSOURCES = $(am__append_1)
diff --git a/community/gnome-bluetooth/udev-hwdb.patch b/community/gnome-bluetooth/udev-hwdb.patch
new file mode 100644
index 0000000000..3fd7cae67c
--- /dev/null
+++ b/community/gnome-bluetooth/udev-hwdb.patch
@@ -0,0 +1,46 @@
+diff --git a/lib/pin.c b/lib/pin.c
+index 61e87ab..fa05599 100644
+--- a/lib/pin.c
++++ b/lib/pin.c
+@@ -40,11 +40,12 @@
+ char *
+ oui_to_vendor (const char *oui)
+ {
++ char *vendor = NULL;
++#if HAVE_UDEV_HWDB_NEW
+ struct udev *udev;
+ struct udev_hwdb *hwdb;
+ struct udev_list_entry *list, *l;
+ char *modalias;
+- char *vendor = NULL;
+
+ if (oui == NULL ||
+ strlen (oui) < 8)
+@@ -81,7 +82,7 @@ bail:
+ g_clear_pointer (&modalias, g_free);
+ g_clear_pointer (&hwdb, udev_hwdb_unref);
+ g_clear_pointer (&udev, udev_unref);
+-
++#endif
+ return vendor;
+ }
+
+@@ -207,7 +208,7 @@ get_pincode_for_device (guint type,
+ data.confirm = TRUE;
+
+ tmp_vendor = oui_to_vendor (address);
+- data.vendor = g_ascii_strdown (tmp_vendor, -1);
++ data.vendor = g_ascii_strdown (tmp_vendor ? tmp_vendor : "unknown", -1);
+ g_free (tmp_vendor);
+
+ ctx = g_markup_parse_context_new (&parser, 0, &data, NULL);
+@@ -227,7 +228,8 @@ get_pincode_for_device (guint type,
+
+ g_debug ("Got pin '%s' (max digits: %d, confirm: %d) for device '%s' (type: %s address: %s, vendor: %s)",
+ data.ret_pin, data.max_digits, data.confirm,
+- name ? name : "", bluetooth_type_to_string (type), address, data.vendor);
++ name ? name : "", bluetooth_type_to_string (type), address,
++ data.vendor ? data.vendor : "unknown");
+
+ g_free (data.vendor);
+