aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-doc-utils/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-23 06:02:10 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-11-17 18:12:18 +0100
commit162ce9e7be579a0163a52ae994ceba87a5caa63c (patch)
tree4187ebb50358bcfab27b3cd7318e4b5cf8e5b74a /community/gnome-doc-utils/APKBUILD
parentbccbb3d348031c40e7d00416b22974c2bf4b6a02 (diff)
downloadaports-162ce9e7be579a0163a52ae994ceba87a5caa63c.tar.bz2
aports-162ce9e7be579a0163a52ae994ceba87a5caa63c.tar.xz
community/gnome-doc-utils: move from main
Nobody in main/ uses it, so move it to community/ where evince uses it
Diffstat (limited to 'community/gnome-doc-utils/APKBUILD')
-rw-r--r--community/gnome-doc-utils/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/gnome-doc-utils/APKBUILD b/community/gnome-doc-utils/APKBUILD
new file mode 100644
index 0000000000..a3c474bce8
--- /dev/null
+++ b/community/gnome-doc-utils/APKBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnome-doc-utils
+pkgver=0.20.10
+pkgrel=4
+pkgdesc="Documentation utilities for Gnome"
+url="https://www.gnome.org/"
+arch="noarch"
+license="GPL-2.0-or-later LGPL-2.1-or-later"
+depends="python3 docbook-xml rarian py3-libxml2 libxslt"
+makedepends="libxslt-dev libxml2-dev perl-xml-parser rarian-dev
+ gettext-dev intltool"
+subpackages="$pkgname-lang $pkgname-doc"
+source="https://download.gnome.org/sources/gnome-doc-utils/${pkgver%.*}/gnome-doc-utils-$pkgver.tar.xz
+ python3.patch
+ "
+
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-scrollkeeper \
+ --enable-build-utils
+ make
+ sed -i s/python$/python3/g xml2po/xml2po/xml2po
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="1cb5e3b9ca9e45e6c551801e9c9c4aac725c2ce85238c230a4c70b36c90419886b921d8dd464df0643fc3bbb877df075abaa83a36d1609c5664960c31e11d151 gnome-doc-utils-0.20.10.tar.xz
+bc0093b589f8a6d2ef5cd83d4ca5cfe86281b0196963cb6d8dee0c54f915af1b5d05c64f62585f9360deb53cd60a313575db5eca976f4bc548a4e28535612c1d python3.patch"