aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-session
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-23 00:16:44 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-23 00:16:44 +0200
commit96639432098af0abec8af797d4cf43d2c4322815 (patch)
tree5229648a7aad941f754fa34c3f70dac05120356e /community/gnome-session
parent6b338891c27a1a191d01a5d5e1b59f5ca5c1c992 (diff)
downloadaports-96639432098af0abec8af797d4cf43d2c4322815.tar.bz2
aports-96639432098af0abec8af797d4cf43d2c4322815.tar.xz
community/gnome-session: move from testing
Diffstat (limited to 'community/gnome-session')
-rw-r--r--community/gnome-session/APKBUILD36
-rw-r--r--community/gnome-session/fail-whale-dialog.patch35
-rw-r--r--community/gnome-session/no-rpmatch.patch15
3 files changed, 86 insertions, 0 deletions
diff --git a/community/gnome-session/APKBUILD b/community/gnome-session/APKBUILD
new file mode 100644
index 0000000000..9dcda2c4fe
--- /dev/null
+++ b/community/gnome-session/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gnome-session
+pkgver=3.34.0
+pkgrel=0
+pkgdesc="GNOME session manager"
+url="https://gitlab.gnome.org/GNOME/gnome-session"
+arch="all !armhf !s390x !ppc64le"
+license="GPL-2.0-or-later"
+depends="gnome-shell polkit alsa-plugins-pulse dconf pulseaudio-alsa"
+makedepends="gnome-settings-daemon-dev libsm-dev
+ elogind-dev itstool libxslt libxml2-utils json-glib-dev gnome-desktop-dev
+ gtk+3.0-dev startup-notification-dev upower-dev meson py3-setuptools xmlto
+ docbook-xml"
+options="!check" #no tests
+subpackages="$pkgname-lang $pkgname-doc"
+source="https://download.gnome.org/sources/gnome-session/${pkgver%.*}/gnome-session-$pkgver.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ -Dsystemd_journal=true \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="36a42e2c6b991df8d79ecbf73221c39a05fc13a7f0dffb9b92a7c544b98b481e41f5eb40016049903e9083842b8db84429cfae1cb66cd4de07c62a961f73aee4 gnome-session-3.34.0.tar.xz"
diff --git a/community/gnome-session/fail-whale-dialog.patch b/community/gnome-session/fail-whale-dialog.patch
new file mode 100644
index 0000000000..e7a54f57f0
--- /dev/null
+++ b/community/gnome-session/fail-whale-dialog.patch
@@ -0,0 +1,35 @@
+$OpenBSD: patch-gnome-session_gsm-fail-whale-dialog_c,v 1.1 2017/05/30 18:14:03 ajacoutot Exp $
+
+https://bugzilla.gnome.org/show_bug.cgi?id=775463
+
+Index: gnome-session/gsm-fail-whale-dialog.c
+--- a/gnome-session/gsm-fail-whale-dialog.c.orig
++++ b/gnome-session/gsm-fail-whale-dialog.c
+@@ -371,13 +371,20 @@ int main (int argc, char *argv[])
+ bind_textdomain_codeset (GETTEXT_PACKAGE, "UTF-8");
+ textdomain (GETTEXT_PACKAGE);
+
+- gtk_init_with_args (&argc, &argv, " - fail whale",
+- entries, GETTEXT_PACKAGE,
+- &error);
+- if (error != NULL) {
+- g_warning ("%s", error->message);
+- exit (1);
+- }
++ if (!gtk_init_with_args (&argc, &argv, " - fail whale",
++ entries, GETTEXT_PACKAGE,
++ &error)) {
++ if (error != NULL) {
++ g_warning ("%s", error->message);
++ exit (1);
++ }
++
++ /* display server probably went away. Could be for legitimate reasons, could be for
++ * unexpected reasons. If it went away unexpectantly, that's logged elsewhere, so
++ * let's not add noise by logging here.
++ */
++ return 0;
++ }
+
+ fail_dialog = g_object_new (GSM_TYPE_FAIL_WHALE_DIALOG, NULL);
+ fail_dialog->priv->debug_mode = debug_mode;
diff --git a/community/gnome-session/no-rpmatch.patch b/community/gnome-session/no-rpmatch.patch
new file mode 100644
index 0000000000..ea41bf46e5
--- /dev/null
+++ b/community/gnome-session/no-rpmatch.patch
@@ -0,0 +1,15 @@
+$OpenBSD: patch-gnome-session_main_c,v 1.19 2017/04/17 10:51:02 ajacoutot Exp $
+
+XXX no rpmatch(3) on OpenBSD
+
+--- a/gnome-session/main.c.orig Wed Apr 12 16:35:48 2017
++++ b/gnome-session/main.c Mon Apr 17 12:40:35 2017
+@@ -311,7 +311,7 @@ main (int argc, char **argv)
+
+ debug_string = g_getenv ("GNOME_SESSION_DEBUG");
+ if (debug_string != NULL) {
+- debug = rpmatch (debug_string) == TRUE || atoi (debug_string) == 1;
++ debug = atoi (debug_string) == 1;
+ }
+
+ error = NULL;