aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-shell
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-05-02 14:36:26 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-02 14:36:26 +0200
commitb810e682dddcc6d438a2a9d77d95bb2d04514c11 (patch)
tree02d4f7af003828fe5519661abf95a67b9a9f72ed /community/gnome-shell
parentbe3422af39d2507bfb3ed3a3cb8652097dc4bef8 (diff)
downloadaports-b810e682dddcc6d438a2a9d77d95bb2d04514c11.tar.bz2
aports-b810e682dddcc6d438a2a9d77d95bb2d04514c11.tar.xz
community/gnome-shell: fix start with telepathy-logger installed
Diffstat (limited to 'community/gnome-shell')
-rw-r--r--community/gnome-shell/APKBUILD8
-rw-r--r--community/gnome-shell/disable-telepathy-integration.patch17
2 files changed, 22 insertions, 3 deletions
diff --git a/community/gnome-shell/APKBUILD b/community/gnome-shell/APKBUILD
index c4c6e3b9b5..50054fef77 100644
--- a/community/gnome-shell/APKBUILD
+++ b/community/gnome-shell/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-shell
pkgver=3.36.2
-pkgrel=2
+pkgrel=3
pkgdesc="GNOME shell"
url="https://wiki.gnome.org/Projects/GnomeShell"
arch="all !s390x !ppc64le !mips !mips64"
@@ -56,7 +56,8 @@ checkdepends="
gdm
"
subpackages="$pkgname-lang $pkgname-doc $pkgname-dbg"
-source="https://download.gnome.org/sources/gnome-shell/${pkgver%.*}/gnome-shell-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/gnome-shell/${pkgver%.*}/gnome-shell-$pkgver.tar.xz
+ disable-telepathy-integration.patch"
options="!check" # Tests have circular dependency 'gnome-shell <-> gdm'
build() {
@@ -81,4 +82,5 @@ package() {
setcap cap_sys_nice+ep "$pkgdir"/usr/bin/gnome-shell
}
-sha512sums="5f4950e5570863f7951423286c066376a9d8221a99929a2ca26493f21f9230d89ad67ca48d9e94aa47ccc3fd83490edffbc2d4c5fd2f0d2c2ff6420975cdbb85 gnome-shell-3.36.2.tar.xz"
+sha512sums="5f4950e5570863f7951423286c066376a9d8221a99929a2ca26493f21f9230d89ad67ca48d9e94aa47ccc3fd83490edffbc2d4c5fd2f0d2c2ff6420975cdbb85 gnome-shell-3.36.2.tar.xz
+2ca70115fab957fdf276b7f0772786e1afd56b0b22bcfd92f5b5f1d29676dc97c19cfb079434d0dbf7b459f1d133dbd8d1faa0d88f7b94846040a23856f951f8 disable-telepathy-integration.patch"
diff --git a/community/gnome-shell/disable-telepathy-integration.patch b/community/gnome-shell/disable-telepathy-integration.patch
new file mode 100644
index 0000000000..afce81904e
--- /dev/null
+++ b/community/gnome-shell/disable-telepathy-integration.patch
@@ -0,0 +1,17 @@
+Upstream: No, this is on our telepathy being broken somehow.
+Reason: This is a hotfix to not break everyone's GNOME Session over this.
+Issue opened, see: https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/2733
+
+diff --git a/js/ui/components/telepathyClient.js b/js/ui/components/telepathyClient.js
+index b4af438..109d324 100644
+--- a/js/ui/components/telepathyClient.js
++++ b/js/ui/components/telepathyClient.js
+@@ -18,7 +18,7 @@ const MessageTray = imports.ui.messageTray;
+ const Params = imports.misc.params;
+ const Util = imports.misc.util;
+
+-const HAVE_TP = Tp != null && Tpl != null;
++const HAVE_TP = false;
+
+ // See Notification.appendMessage
+ var SCROLLBACK_IMMEDIATE_TIME = 3 * 60; // 3 minutes