aboutsummaryrefslogtreecommitdiffstats
path: root/community/gns3-server
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-04-07 21:21:56 +0000
committerBreno Leitao <breno.leitao@gmail.com>2017-04-07 21:34:04 +0000
commit625aa15d09d4e3704ba949f7e86ea50b66cc1017 (patch)
tree94741fdd88391d2ca1a80382ff4546f67b6d800d /community/gns3-server
parent42687d1df0615f1e6094e4d28bed65a29b55be79 (diff)
downloadaports-625aa15d09d4e3704ba949f7e86ea50b66cc1017.tar.bz2
aports-625aa15d09d4e3704ba949f7e86ea50b66cc1017.tar.xz
testing/gns3-server: Fix stripping non-intel binaries
Currently gns3-server keeps a x86 binary as part of the source package, and this package currently fails on non-x86 machines on the strip() step. Replacing the x86 binary by the build server binary.
Diffstat (limited to 'community/gns3-server')
-rw-r--r--community/gns3-server/APKBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/community/gns3-server/APKBUILD b/community/gns3-server/APKBUILD
index c6159ce634..d7c6117a46 100644
--- a/community/gns3-server/APKBUILD
+++ b/community/gns3-server/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=gns3-server
pkgver=1.5.3.3
-pkgrel=1
+pkgrel=2
pkgdesc="GNS3 network simulator. Server package."
url="https://github.com/GNS3/gns3-server"
arch="all"
license="GPL3"
-depends="dynamips python3 py3-psutil py3-jinja2 py3-aiohttp py3-pytest
+depends="busybox dynamips python3 py3-psutil py3-jinja2 py3-aiohttp py3-pytest
py3-netifaces py3-ws4py py3-zipstream py3-raven py3-jsonschema"
depends_dev=""
makedepends="$depends_dev py-setuptools python3-dev linux-headers py3-pytest"
@@ -16,6 +16,15 @@ subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/GNS3/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$builddir"
+ # Current upstream contains arch dependent (x86) binaries in the
+ # source package. Replacing it with the binary from the build server.
+ # https://github.com/GNS3/gns3-server/issues/970
+ cp /bin/busybox gns3server/modules/docker/resources/bin/busybox
+}
+
build() {
cd "$builddir"
python3 setup.py build || return 1