aboutsummaryrefslogtreecommitdiffstats
path: root/community/gns3-server
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-05-02 21:34:55 +0000
committerBreno Leitao <breno.leitao@gmail.com>2017-05-02 21:51:23 +0000
commitdd7bea2d8f82f1da676ed0af2118acf86bdd8554 (patch)
treef1f99026027331f3e185287fa223fe567a032880 /community/gns3-server
parent211cf411be418ad5cef4e3e89a2f9928c6220c79 (diff)
downloadaports-dd7bea2d8f82f1da676ed0af2118acf86bdd8554.tar.bz2
aports-dd7bea2d8f82f1da676ed0af2118acf86bdd8554.tar.xz
community/gns3-server: Replace x86_64 binary
Upstream currently ships a x86_64 binary in the source code. It should be replaced by the current package architecture.
Diffstat (limited to 'community/gns3-server')
-rw-r--r--community/gns3-server/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/gns3-server/APKBUILD b/community/gns3-server/APKBUILD
index 91b427b213..495703dd50 100644
--- a/community/gns3-server/APKBUILD
+++ b/community/gns3-server/APKBUILD
@@ -11,8 +11,6 @@ depends="busybox dynamips python3 py3-psutil py3-jinja2 py3-aiohttp
py3-pytest py3-netifaces py3-ws4py py3-zipstream py3-raven py3-jsonschema"
makedepends="py-setuptools python3-dev linux-headers py3-pytest"
subpackages="$pkgname-doc"
-# the onlyl binary we have is a static busybox which we dont need to strip
-options="!strip"
source="$pkgname-$pkgver.tar.gz::https://github.com/GNS3/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
@@ -24,6 +22,12 @@ check() {
build() {
cd "$builddir"
+ # Upstream includes busybox binary for x86_64. We want to replace it by
+ # $CARCH binary
+ if [ "$CARCH" != "x86_64" ] ; then
+ busybox_bin=$(find . -name busybox -type f)
+ cp /bin/busybox.static $busybox_bin
+ fi
python3 setup.py build
}