aboutsummaryrefslogtreecommitdiffstats
path: root/community/gns3-server
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-11-22 03:01:17 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-11-22 03:01:17 +0000
commitf5af506a9bd7bdfbc54458bce54febefbffa5123 (patch)
tree77f113d757e40bde725c64e425e3999d020e472a /community/gns3-server
parent69ac7474ac479b112dbd8d68888690b28b4d068a (diff)
downloadaports-f5af506a9bd7bdfbc54458bce54febefbffa5123.tar.bz2
aports-f5af506a9bd7bdfbc54458bce54febefbffa5123.tar.xz
community/gns3-server: upgrade to 2.1.0
Diffstat (limited to 'community/gns3-server')
-rw-r--r--community/gns3-server/APKBUILD27
-rw-r--r--community/gns3-server/dropped-requirements.patch20
-rw-r--r--community/gns3-server/gns3-server-aiohttp.patch15
3 files changed, 40 insertions, 22 deletions
diff --git a/community/gns3-server/APKBUILD b/community/gns3-server/APKBUILD
index 80086f9f70..5f3f8b66c8 100644
--- a/community/gns3-server/APKBUILD
+++ b/community/gns3-server/APKBUILD
@@ -1,27 +1,22 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=gns3-server
-pkgver=2.0.3
-pkgrel=1
+pkgver=2.1.0
+pkgrel=0
pkgdesc="GNS3 network simulator. Server package."
url="https://github.com/GNS3/gns3-server"
arch="all"
license="GPL3"
-depends="busybox dynamips python3 py3-psutil py3-jinja2 py3-aiohttp1
- py3-aiohttp1-cors py3-pytest py3-netifaces py3-ws4py py3-zipstream
- py3-raven py3-jsonschema py3-yarl"
+depends="busybox dynamips python3 py3-psutil py3-jinja2 py3-aiohttp
+ py3-aiohttp-cors py3-pytest py3-netifaces py3-ws4py py3-zipstream
+ py3-raven py3-jsonschema py3-yarl py3-multidict py3-prompt_toolkit"
makedepends="busybox-static py-setuptools python3-dev linux-headers py3-pytest"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/GNS3/$pkgname/archive/v$pkgver.tar.gz
+ gns3-server-aiohttp.patch
dropped-requirements.patch"
-
builddir="$srcdir"/$pkgname-$pkgver
-check() {
- cd "$builddir"
- python3 setup.py check
-}
-
build() {
cd "$builddir"
# Upstream includes busybox binary for x86_64. We want to replace it by
@@ -33,6 +28,11 @@ build() {
python3 setup.py build
}
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
package() {
cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
@@ -51,5 +51,6 @@ EOF
}
-sha512sums="0bbecba9c0b74846f458a7da7d8c041cf6320c5ce4b388bc1e8fd10a8dc52224282b537c309a5a0277bff78bd2c8a0f1df5a100b94f8321d2b9929ce3a88f06d gns3-server-2.0.3.tar.gz
-e698dd1165b4493c8b467618ccffd31395af5832975a520a239fb03ec62678c3528f386eadd309686bd2cd73b89246c225510cc08bec5ff7389f2de84a380ca3 dropped-requirements.patch"
+sha512sums="fe85cee40308912c1b530e74301302cdbc44c60092f245cf87da4ee1355dc577c69d6f2c4f6c2018208c425e1b7e51671397494b73c810b6cde8a35c07a0bff3 gns3-server-2.1.0.tar.gz
+f0056c89db5304bd4ac509ff9b1f84b612ec72a90316d5b7761e1734d7e944d232756514f3e2266ab9988f597aa58b7d9d6f66d9bd69deb6d554c1d2fdbda21f gns3-server-aiohttp.patch
+e324e1d1580a400671d93195b8be18df44d5a7da46dc5a9bbf493ea60d68d85bda609f45a59ecedb4e6a91ccf7342974fb3bb966546ca6881b838d4ccb9ddc0e dropped-requirements.patch"
diff --git a/community/gns3-server/dropped-requirements.patch b/community/gns3-server/dropped-requirements.patch
index f9ad1c9ca9..77a05343e2 100644
--- a/community/gns3-server/dropped-requirements.patch
+++ b/community/gns3-server/dropped-requirements.patch
@@ -1,17 +1,19 @@
diff --git a/requirements.txt b/requirements.txt
-index 648cf5f..1c81f17 100644
+index 2d88225..92b19c4 100644
--- a/requirements.txt
+++ b/requirements.txt
-@@ -1,9 +1,8 @@
+@@ -1,11 +1,11 @@
jsonschema>=2.4.0
--aiohttp>=1.3.5,<=1.4.0 # pyup: ignore
--aiohttp-cors==0.5.1 # pyup: ignore
--yarl>=0.9.8,<0.10 # pyup: ignore
-+aiohttp>=1.3.5 # pyup: ignore
-+aiohttp-cors>=0.5.1 # pyup: ignore
-+yarl>=0.9.8 # pyup: ignore
+-aiohttp>=2.2.0,<2.3.0 # pyup: ignore
++aiohttp>=2.2.0,<2.3.4 # pyup: ignore
+ aiohttp-cors>=0.5.3,<0.6.0 # pyup: ignore
+-yarl>=0.11,<0.12 # pyup: ignore
++yarl>=0.11,<0.15 # pyup: ignore
Jinja2>=2.7.3
raven>=5.23.0
psutil>=3.0.0
zipstream>=1.1.4
--typing>=3.5.3.0 # Otherwise yarl fail with python 3.4
+ typing>=3.5.3.0 # Otherwise yarl fails with python 3.4
+-multidict<3.2.0 # Otherwise fails when upgraded to v3.2.0
++multidict<3.4.0 # Otherwise fails when upgraded to v3.2.0
+ prompt-toolkit
diff --git a/community/gns3-server/gns3-server-aiohttp.patch b/community/gns3-server/gns3-server-aiohttp.patch
new file mode 100644
index 0000000000..e27d129c8e
--- /dev/null
+++ b/community/gns3-server/gns3-server-aiohttp.patch
@@ -0,0 +1,15 @@
+diff --git a/gns3server/web/web_server.py b/gns3server/web/web_server.py
+index 8352134..53a8252 100644
+--- a/gns3server/web/web_server.py
++++ b/gns3server/web/web_server.py
+@@ -42,8 +42,8 @@ import gns3server.handlers
+ import logging
+ log = logging.getLogger(__name__)
+
+-if not aiohttp.__version__.startswith("2.2"):
+- raise RuntimeError("aiohttp 2.2 is required to run the GNS3 server")
++if not aiohttp.__version__.startswith("2.3"):
++ raise RuntimeError("aiohttp 2.3 is required to run the GNS3 server")
+
+
+ class WebServer: