aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnuplot
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-11-01 18:35:25 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2017-11-01 19:42:32 +0100
commit449e41cc6ad78d6ad81a61b599449df63ea72f92 (patch)
treedc6aaf6f3466633ca61bdf4ed484ef4c03c59106 /community/gnuplot
parent0a1fb0d91a5354d312ed66ff48393d405b8f522e (diff)
downloadaports-449e41cc6ad78d6ad81a61b599449df63ea72f92.tar.bz2
aports-449e41cc6ad78d6ad81a61b599449df63ea72f92.tar.xz
community/gnuplot: modernize APKBUILD
Diffstat (limited to 'community/gnuplot')
-rw-r--r--community/gnuplot/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/community/gnuplot/APKBUILD b/community/gnuplot/APKBUILD
index 63ad08c6ce..21e6d7044b 100644
--- a/community/gnuplot/APKBUILD
+++ b/community/gnuplot/APKBUILD
@@ -25,18 +25,17 @@ build() {
--localstatedir=/var \
--enable-stats \
--disable-wxwidgets \
- --disable-qt \
- || return 1
- make || return 1
+ --disable-qt
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
install -m644 BUGS ChangeLog NEWS PGPKEYS PORTING README* \
- "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+ "$pkgdir"/usr/share/doc/$pkgname/
}
sha512sums="7f9b05725a8594dcfbf1f1fc8f1db9bf45e1b6841fa1089b2c2528a3e36f71baab16d5fbeb027e4dd3618461a4895d037cb9f43781bfee2cb078cb9583567d8d gnuplot-5.0.6.tar.gz"