aboutsummaryrefslogtreecommitdiffstats
path: root/community/go
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-07-08 05:55:57 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-07-08 05:57:04 +0000
commit229be22b22545d4c3230dfcde075e4a708594b32 (patch)
tree0ec90fe48e9204f86153f4e8c583f5b972983fa0 /community/go
parentb1e1a9a87595458018b6e0e611679e30c142652f (diff)
downloadaports-229be22b22545d4c3230dfcde075e4a708594b32.tar.bz2
aports-229be22b22545d4c3230dfcde075e4a708594b32.tar.xz
community/go: upgrade to 1.7rc1
Fixes x86 build errors. vet removed from external tools as it is part of main go package now.
Diffstat (limited to 'community/go')
-rw-r--r--community/go/APKBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 75814a3796..35d9818ad9 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Eivind Uggedal <eivind@uggedal.com>
pkgname=go
-pkgver=1.6.2
+pkgver=1.7_rc1
# This should be the latest commit on the corresponding release branch
-_toolsver="c887be1b2ebd11663d4bf2fbca508c449172339e"
-pkgrel=5
+_toolsver="527b253f588776e5f72a0a0d1e93195cd3f82707"
+pkgrel=0
pkgdesc="Go programming language compiler"
url="http://www.golang.org/"
arch="all"
@@ -15,15 +15,15 @@ makedepends="bash go-bootstrap paxmark"
options="!strip"
install=""
subpackages="$pkgname-doc $pkgname-tools $pkgname-cross"
-source="http://golang.org/dl/go${pkgver}.src.tar.gz
- $pkgname-tools-$pkgver.tar.gz::https://github.com/golang/tools/archive/${_toolsver}.tar.gz
+source="http://golang.org/dl/go${pkgver/_/}.src.tar.gz
+ $pkgname-tools-${pkgver/_/}.tar.gz::https://github.com/golang/tools/archive/${_toolsver}.tar.gz
default-buildmode-pie.patch
"
# NOTE: building go for x86 with grsec kernel requires:
# sysctl -w kernel.modify_ldt=1
-_gotools="cover vet godoc stringer"
+_gotools="cover godoc stringer"
_gocross="darwin freebsd openbsd windows"
_builddir="$srcdir"/$pkgname
@@ -145,12 +145,12 @@ cross() {
"$subpkgdir"/usr/lib/go/pkg || return 1
done
}
-md5sums="d1b50fa98d9a71eeee829051411e6207 go1.6.2.src.tar.gz
-733a96b59562ed84ff552542f16a3ab3 go-tools-1.6.2.tar.gz
+md5sums="9235e0a992216ae400eb1a3bd350259f go1.7rc1.src.tar.gz
+24099025de8422aa8b50341ea71bad0e go-tools-1.7rc1.tar.gz
1e3ad4f657ac6c22a92e8fc907893e4f default-buildmode-pie.patch"
-sha256sums="787b0b750d037016a30c6ed05a8a70a91b2e9db4bd9b1a2453aa502a63f1bccc go1.6.2.src.tar.gz
-955e5a119babad356d9cf00cdaaf3c27648d4451109b467c872fad8cc94d5b56 go-tools-1.6.2.tar.gz
+sha256sums="f26b42ea8d3de92efda5e2f7172b22d59e19676f23bbcf64412b32b4f4a5ff58 go1.7rc1.src.tar.gz
+89819a5a457d1771bc5960079ed6f0e2870c81aafd3e0b13f0b82fc2427a1220 go-tools-1.7rc1.tar.gz
f3e5a8e0c1c05c34f489ccbfb65291ab2265fa0ef04b8b501e5c98b17547c4b9 default-buildmode-pie.patch"
-sha512sums="e148022f9e18b5d5b05744f1aa9fa3ef82e255752179545711ade077e271216aa5b450859a764fdfb028ae4faa26adad8d0a0a5268b31396ab9d14de3cb2f20a go1.6.2.src.tar.gz
-955def7cc3e5ceb5d8e47477400007d32c25f3bc2764f04a0451bd0235af507e63a0966d201a345f51ac764471da8620b5357d1099ec39e2422bd04d25fd71b8 go-tools-1.6.2.tar.gz
+sha512sums="3c4fee4ebc8ac0e1eeb36b5583263b9c28952ecd93c6dfba6696dec820f41b4f1cb27b9d630d94d066df00c06e11a748542a06ddccbc66a7c9a80e8e2906dd8f go1.7rc1.src.tar.gz
+c298f821033f9db3cd100e38346474c3982417958f347078abfff895834964251269116535e46aa5c2a9e58c421928b874ea98e5c5cd65a83c0b64ae04029d3e go-tools-1.7rc1.tar.gz
13cd386c38875b951da4057586007f3c67503dc79ddf57befbf763af85ec2cd2a2e6b00614450c179c93f1f8747ee7456ee412adccd08a5f115b33812598a148 default-buildmode-pie.patch"