aboutsummaryrefslogtreecommitdiffstats
path: root/community/go
diff options
context:
space:
mode:
authorKeegan Carruthers-Smith <keegan.csmith@gmail.com>2016-08-19 13:44:16 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-08-19 19:04:03 +0000
commit3973cebebe48a1f158cf1f3fc884bb4510412408 (patch)
tree184e5e81a039586c15bc394e19b3ed2021375ac1 /community/go
parent87542cd4832cd299e454538b73dfc938cce038e3 (diff)
downloadaports-3973cebebe48a1f158cf1f3fc884bb4510412408.tar.bz2
aports-3973cebebe48a1f158cf1f3fc884bb4510412408.tar.xz
community/go: upgrade to 1.7
Diffstat (limited to 'community/go')
-rw-r--r--community/go/APKBUILD23
1 files changed, 8 insertions, 15 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 89f986a046..5352bf49a4 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Eivind Uggedal <eivind@uggedal.com>
pkgname=go
-pkgver=1.7_rc4
+pkgver=1.7
# This should be the latest commit on the corresponding release branch
-_toolsver="527b253f588776e5f72a0a0d1e93195cd3f82707"
+_toolsver="26c35b4dcf6dfcb924e26828ed9f4d028c5ce05a"
pkgrel=0
pkgdesc="Go programming language compiler"
url="http://www.golang.org/"
@@ -81,13 +81,6 @@ package() {
cd "$builddir"
mkdir -p "$pkgdir"/usr/bin "$pkgdir"/usr/lib/go/bin "$pkgdir"/usr/share/doc/go
- # go before 1.7 has issues with randmmap on arm
- # https://github.com/golang/go/issues/16081
- if [ "$GOARCH" = "arm" ]; then
- paxmark -r bin/go || attr -s pax.flags -V "rx" bin/go \
- || return 1
- fi
-
for binary in go gofmt; do
mv bin/"$binary" "$pkgdir"/usr/lib/go/bin/ || return 1
ln -s /usr/lib/go/bin/"$binary" "$pkgdir"/usr/bin/ || return 1
@@ -149,15 +142,15 @@ cross() {
done
}
-md5sums="c55787c07d3fdc3eba0eae28c2f16ce7 go1.7rc4.src.tar.gz
-24099025de8422aa8b50341ea71bad0e go-tools-1.7rc4.tar.gz
+md5sums="a30c3bd1a7fcc6a48acfb74936a19b4c go1.7.src.tar.gz
+9e14a20ca24062e0855293bc8d38c00b go-tools-1.7.tar.gz
1e3ad4f657ac6c22a92e8fc907893e4f default-buildmode-pie.patch
3bda1b07117ed599a991877465eaffdd go-linux-musl-arm64-bootstrap.tar.bz2"
-sha256sums="f669d64cd28be4ecaa36d3a31c3060b4f6e3f801e2e37f91c3a896ce3d28f64d go1.7rc4.src.tar.gz
-89819a5a457d1771bc5960079ed6f0e2870c81aafd3e0b13f0b82fc2427a1220 go-tools-1.7rc4.tar.gz
+sha256sums="72680c16ba0891fcf2ccf46d0f809e4ecf47bbf889f5d884ccb54c5e9a17e1c0 go1.7.src.tar.gz
+b796a67a568ca0df5a5a9a1870703db281b17907f812b9cf6ff42568f6764275 go-tools-1.7.tar.gz
f3e5a8e0c1c05c34f489ccbfb65291ab2265fa0ef04b8b501e5c98b17547c4b9 default-buildmode-pie.patch
a1d870570317f5e87c606d6bad0d435a594fed802c99475ab306768dc853a029 go-linux-musl-arm64-bootstrap.tar.bz2"
-sha512sums="496bc1e65dd9fed4fb3c5d5ef636e5559b03b991c04af9165069d63aab2fda36fcd4bcb63021a62601f2690558c9f3888f8d66e577212143831c9dc644ca0614 go1.7rc4.src.tar.gz
-c298f821033f9db3cd100e38346474c3982417958f347078abfff895834964251269116535e46aa5c2a9e58c421928b874ea98e5c5cd65a83c0b64ae04029d3e go-tools-1.7rc4.tar.gz
+sha512sums="a9cd1279927ca50e083dcf6d5a4bcb3bff6a156b3555608334a41be9613b5002dd71caafa472aae6210b01a6cdbd6aa6a55b8882a8e4bda68a5ffd10a3ae1d14 go1.7.src.tar.gz
+553be713d03f1a53605c41f67822c75d86dacf9ccba9f2329e111b4178287aee1ddccd3ccc4ab76b9dbcff34f11aeddebce5deac47e715ea75d032bc9ab0355c go-tools-1.7.tar.gz
13cd386c38875b951da4057586007f3c67503dc79ddf57befbf763af85ec2cd2a2e6b00614450c179c93f1f8747ee7456ee412adccd08a5f115b33812598a148 default-buildmode-pie.patch
da2a33c7bafe11bdad12e755bfe19c9f8ab34ae14899712a0e10da202d5457af419a920be5ffa19cc03d2351194b5c02f1edb595201f81dfb8a51f34b42a8162 go-linux-musl-arm64-bootstrap.tar.bz2"