aboutsummaryrefslogtreecommitdiffstats
path: root/community/go
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-04-18 13:38:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-18 13:48:27 +0000
commit717f370d394f1a79fdf5d58427d65629cd8a8227 (patch)
tree1ef0c669f02b08b62686b161879fd9ac46cdba2d /community/go
parent18905b8349a8581c8976eeb3aed1f0aa26543a4b (diff)
downloadaports-717f370d394f1a79fdf5d58427d65629cd8a8227.tar.bz2
aports-717f370d394f1a79fdf5d58427d65629cd8a8227.tar.xz
community/go: enable build on ppc64le.
Go package build was disabled on ppc64le because it was missing go-bootstrap dependency. As the last version of go-bootstrap (1.4) is not available for ppc64le, I cross-compiled it and uploaded it to: ftp://ftp.unicamp.br/pub/ppc64el/alpine/go-bootstrap/ The go-bootstrap is now installed in build-edge-ppc64le and can compile the go package.
Diffstat (limited to 'community/go')
-rw-r--r--community/go/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 9810afda9a..10f21acbb6 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -7,7 +7,7 @@ _toolsver="26c35b4dcf6dfcb924e26828ed9f4d028c5ce05a"
pkgrel=2
pkgdesc="Go programming language compiler"
url="http://www.golang.org/"
-arch="all !ppc64le"
+arch="all"
license="BSD"
depends="binutils gcc"
depends_dev=""
@@ -56,6 +56,7 @@ build() {
s390x) export GOARCH="s390x" ;;
x86) export GOARCH="386" GO386=387 ;;
x86_64) export GOARCH="amd64" ;;
+ ppc64le) export GOARCH="ppc64le" ;;
*) die "Unsupported arch" ;;
esac