aboutsummaryrefslogtreecommitdiffstats
path: root/community/go
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-10 02:52:40 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-07-12 17:19:46 +0000
commitad25ae4c004c1684a42a1d676267875d6cde0771 (patch)
treee933c2cf4eb691bed56f7887d55c8d0abadf82e1 /community/go
parentcbd8ac4138405b5566ff749b281607f3150bbce6 (diff)
downloadaports-ad25ae4c004c1684a42a1d676267875d6cde0771.tar.bz2
aports-ad25ae4c004c1684a42a1d676267875d6cde0771.tar.xz
community/go: upgrade to 1.12.7
Closes GH-9391
Diffstat (limited to 'community/go')
-rw-r--r--community/go/APKBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 71034f6176..ee6b1825d8 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -2,17 +2,15 @@
# Contributor: Eivind Uggedal <eu@eju.no>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=go
-pkgver=1.12.6
+pkgver=1.12.7
pkgrel=0
pkgdesc="Go programming language compiler"
-url="http://www.golang.org/"
+url="https://golang.org/"
arch="all"
-license="BSD"
+license="BSD-3-Clause"
depends="binutils gcc"
-depends_dev=""
makedepends="bash"
checkdepends="binutils-gold"
-install=""
subpackages="$pkgname-doc"
source="https://golang.org/dl/go${pkgver/_/}.src.tar.gz
default-buildmode-pie.patch
@@ -20,7 +18,7 @@ source="https://golang.org/dl/go${pkgver/_/}.src.tar.gz
"
case "$CARCH" in
-x86) options="!check" ;; # FIXME
+ x86) options="!check" ;; # FIXME
esac
# secfixes:
@@ -33,7 +31,7 @@ esac
# sysctl -w kernel.modify_ldt=1
# The following tests fail currently, most of them fail due to linking
-# errors likely related to `default-buildmode-pie.patch` or musl libc.
+# errors likely related to 'default-buildmode-pie.patch' or musl libc.
_brokentests="runtime debug/gosym cmd/.* cgo.* go_test:os/exec ^test.*"
if [ "$CBUILD" = "$CTARGET" ]; then
@@ -102,7 +100,6 @@ check() {
}
package() {
- cd "$builddir"
mkdir -p "$pkgdir"/usr/bin "$pkgdir"/usr/lib/go/bin "$pkgdir"/usr/share/doc/go
for binary in go gofmt; do
@@ -129,6 +126,6 @@ package() {
-exec rm -rf \{\} \+
}
-sha512sums="431a0b916ce2e64d816808a04bc3bf028e955538ab55c571021c08e599781ae344487a55e119bb3aae3d32f84cd83e2c176dc72d336b95da0352edffeab07a48 go1.12.6.src.tar.gz
+sha512sums="f84c6b89dea9df21f0efa07564eb80baeee5bc2d68cced5fd645ebb32e9317e60b657afe011c81e7739d8a93e4b4dafa0b4f78431a009d36e05de55f89ed0fd6 go1.12.7.src.tar.gz
a8f3afd97992f03ccf2680cde214eefccac47daeb9eeb689b5e0b206ea3c19cfb23d448a4eb532894d830d4b91cd97b249e88f04c17feba02d9e243b40243bd0 default-buildmode-pie.patch
faf8de430df185842902322f064254f3e9ecee0884b3075b5550c85da15ff61ea6c2bb8d0fb7cf3887abc0e40974bd73ee8f8c14da7f914dde7e9220177c4e2a set-external-linker.patch"