aboutsummaryrefslogtreecommitdiffstats
path: root/community/go
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2017-06-08 11:39:02 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-09 15:30:28 +0000
commitb5f0896153bb6ab8a9da807641feb62b83a7f422 (patch)
tree1fca73bd5be6370290f7c367dd6809aea909f135 /community/go
parentf8a9f7639f5a6b1f049b483dc74025fe7f8aa63a (diff)
downloadaports-b5f0896153bb6ab8a9da807641feb62b83a7f422.tar.bz2
aports-b5f0896153bb6ab8a9da807641feb62b83a7f422.tar.xz
community/go: default buildmode=pie on s390x
Diffstat (limited to 'community/go')
-rw-r--r--community/go/APKBUILD4
-rw-r--r--community/go/default-buildmode-pie.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index e4c2636b7b..f0e3ace4a8 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -4,7 +4,7 @@ pkgname=go
pkgver=1.8.1
# This should be the latest commit on the corresponding release branch
_toolsver="5682db0e919ed9cfc6f52ac32e170511a106eb3b"
-pkgrel=1
+pkgrel=2
pkgdesc="Go programming language compiler"
url="http://www.golang.org/"
arch="all"
@@ -169,5 +169,5 @@ _crosspkg() {
sha512sums="f01fe7b35ac23101610f6fc169b88dafe2edc49b3b044d5d0aff771b05dcb2c8d2e7a5090ed6dbe67f861e78e792ace32e209ed464399ca02dcd186b13ec8037 go1.8.1.src.tar.gz
343fca47f250278b22df1c1cd92cce91e01009043d05d8ccce095e4386fa0f5ca8ccaa58232635332c7288ceca9d2a240f774f8bb3b08129a681a582cba60248 go-tools-1.8.1.tar.gz
-13cd386c38875b951da4057586007f3c67503dc79ddf57befbf763af85ec2cd2a2e6b00614450c179c93f1f8747ee7456ee412adccd08a5f115b33812598a148 default-buildmode-pie.patch
+9857c71108652b8907117abf0b41ded5e332bcf864320235aadbf3a7b6afbfc0e5051f91fe143f0654b4c8d6fe9adbe7d22ca2ce50cd75c0ab7a050dfb437773 default-buildmode-pie.patch
6b36f3780ab10e5c4902473a8ab5c0417220ece584b537517e9e60979bdc5a548ed14dd2546605392c89ec5ea6691769d337d34e2e19b92eba5bbca1898f4ada set-external-linker.patch"
diff --git a/community/go/default-buildmode-pie.patch b/community/go/default-buildmode-pie.patch
index 034692a098..1fa8241cd1 100644
--- a/community/go/default-buildmode-pie.patch
+++ b/community/go/default-buildmode-pie.patch
@@ -4,7 +4,7 @@
ldBuildmode = "c-shared"
case "default":
switch platform {
-+ case "linux/386", "linux/amd64", "linux/arm", "linux/arm64", "linux/ppc64le",
++ case "linux/386", "linux/amd64", "linux/arm", "linux/arm64", "linux/ppc64le", "linux/s390x",
+ "android/amd64", "android/arm", "android/arm64", "android/386":
- case "android/arm", "android/arm64", "android/amd64", "android/386":
codegenArg = "-shared"