aboutsummaryrefslogtreecommitdiffstats
path: root/community/go
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-06-17 16:16:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-06-17 16:30:04 +0000
commite7dca0ffe31a8a865554e8818e66b6ab8617434a (patch)
tree38ac62b38d86d77da87d9e5e072799fdabe22142 /community/go
parent971c60eafea1480ebababac8c8d65e1af61fe52a (diff)
downloadaports-e7dca0ffe31a8a865554e8818e66b6ab8617434a.tar.bz2
aports-e7dca0ffe31a8a865554e8818e66b6ab8617434a.tar.xz
community/go: paxmark go on arm
this works around problem when building docker https://github.com/golang/go/issues/16081
Diffstat (limited to 'community/go')
-rw-r--r--community/go/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 67d808993d..0882d920ed 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -4,14 +4,14 @@ pkgname=go
pkgver=1.6.2
# This should be the latest commit on the corresponding release branch
_toolsver="c887be1b2ebd11663d4bf2fbca508c449172339e"
-pkgrel=2
+pkgrel=3
pkgdesc="Go programming language compiler"
url="http://www.golang.org/"
arch="all"
license="BSD"
depends=""
depends_dev=""
-makedepends="bash go-bootstrap"
+makedepends="bash go-bootstrap paxmark"
options="!strip"
install=""
subpackages="$pkgname-doc $pkgname-tools $pkgname-cross"
@@ -78,6 +78,13 @@ package() {
cd "$_builddir"
mkdir -p "$pkgdir"/usr/bin "$pkgdir"/usr/lib/go/bin "$pkgdir"/usr/share/doc/go
+ # go before 1.7 has issues with randmmap on arm
+ # https://github.com/golang/go/issues/16081
+ if [ "$GOARCH" = "arm" ]; then
+ paxmark -r bin/go || attr -s pax.flags -V "r" bin/go \
+ || return 1
+ fi
+
for binary in go gofmt; do
mv bin/"$binary" "$pkgdir"/usr/lib/go/bin/ || return 1
ln -s /usr/lib/go/bin/"$binary" "$pkgdir"/usr/bin/ || return 1