aboutsummaryrefslogtreecommitdiffstats
path: root/community/google-authenticator
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-06-12 13:54:18 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-06-12 13:54:44 +0000
commit229d0e0df446d118264c513b952e7affcca630d8 (patch)
tree2d393806729b35b3df933669d14263570eda4ccf /community/google-authenticator
parent9afc29bfcde8a704bc6bebbc6bfef7490897899a (diff)
downloadaports-229d0e0df446d118264c513b952e7affcca630d8.tar.bz2
aports-229d0e0df446d118264c513b952e7affcca630d8.tar.xz
community/google-authenticator: add PAM file for 'includes'
Remove 'return 1'
Diffstat (limited to 'community/google-authenticator')
-rw-r--r--community/google-authenticator/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/community/google-authenticator/APKBUILD b/community/google-authenticator/APKBUILD
index 4e41b34f8a..e10bcf17e3 100644
--- a/community/google-authenticator/APKBUILD
+++ b/community/google-authenticator/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fabio Napoleoni <f.napoleoni@gmail.com>
pkgname=google-authenticator
pkgver=1.02
-pkgrel=0
+pkgrel=1
pkgdesc="Google Authenticator PAM module"
url="https://github.com/google/google-authenticator"
arch="all"
@@ -27,15 +27,16 @@ build() {
--libdir=/lib \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info \
- || return 1
-
- make || return 1
+ --infodir=/usr/share/info
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
+ mkdir -p "$pkgdir/etc/pam.d"
+ echo -e "auth\trequired\tpam_google_authenticator.so" \
+ > "$pkgdir/etc/pam.d/google-authenticator"
}
sha512sums="8bf81beaf705f0b12f0ed947960dbbc8155add6d83878b651dc1d6658d520dfbbdbe8085b1f244bcfa06d0dd4dfb4cd2177c0a27df4aab5fd1bc4308eef3f7b0 google-authenticator-1.02.tar.gz"