aboutsummaryrefslogtreecommitdiffstats
path: root/community/grilo
diff options
context:
space:
mode:
authorMichael Forney <mforney@mforney.org>2019-12-18 19:28:37 -0800
committerMilan P. Stanić <mps@arvanta.net>2019-12-20 14:23:18 +0100
commitd004f019b6f200366ee7550f3ceee68298aa5707 (patch)
tree0c0a43949f2d3add824297e92bb0f84ba2d26e92 /community/grilo
parent89d12c29fd8a92b461b86db3b582885c93d2d634 (diff)
downloadaports-d004f019b6f200366ee7550f3ceee68298aa5707.tar.bz2
aports-d004f019b6f200366ee7550f3ceee68298aa5707.tar.xz
community/grilo: Check-in patch so that it has a stable checksum
Diffstat (limited to 'community/grilo')
-rw-r--r--community/grilo/APKBUILD4
-rw-r--r--community/grilo/fix-build-with-new-totel-pl-parser.patch36
2 files changed, 38 insertions, 2 deletions
diff --git a/community/grilo/APKBUILD b/community/grilo/APKBUILD
index 3d550b3af1..26fd6a47f2 100644
--- a/community/grilo/APKBUILD
+++ b/community/grilo/APKBUILD
@@ -13,7 +13,7 @@ makedepends="gnome-desktop-dev liboauth-dev gmime-dev libsoup-dev libxml2-dev
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs"
# source="https://download.gnome.org/sources/grilo/0.3/grilo-$pkgver.tar.xz"
source="$pkgname-$pkgver.tar.gz::https://github.com/GNOME/grilo/archive/grilo-$pkgver.tar.gz
- fix-build-with-new-totel-pl-parser.patch::https://gitlab.gnome.org/GNOME/grilo/commit/60d135ef64f16671bb0ab4079ecbc59bdc32cbc7.patch
+ fix-build-with-new-totel-pl-parser.patch
"
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
@@ -35,4 +35,4 @@ package() {
}
sha512sums="9089b0f64fdc4da82a4d087b54af407a37b64214e3553519d76bdafc380406851ed3cd060312b332b3cf67d0a105b72829e245846b47365c7101f52812ffbeda grilo-0.3.10.tar.gz
-a6b5dd6fc7a3ae5026e954c01cfc8cd93fc307620c0e1a46c1062144388fb6e4810d2cd025941147f9af4e22bdce983ab4f3f37b104f12f1a859070571544af4 fix-build-with-new-totel-pl-parser.patch"
+bd0af0e0c390bb610556cd165b1e7317f1cf683f1f2649e4d56f8359803aff7474749e19c8812feefb5c192d9554f4cb5de2857861c3df69d21903c565eab2df fix-build-with-new-totel-pl-parser.patch"
diff --git a/community/grilo/fix-build-with-new-totel-pl-parser.patch b/community/grilo/fix-build-with-new-totel-pl-parser.patch
new file mode 100644
index 0000000000..66d844f791
--- /dev/null
+++ b/community/grilo/fix-build-with-new-totel-pl-parser.patch
@@ -0,0 +1,36 @@
+From 60d135ef64f16671bb0ab4079ecbc59bdc32cbc7 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Tue, 12 Nov 2019 19:44:04 +0100
+Subject: [PATCH] pls: Support totem-pl-parser 3.26.4
+
+---
+ libs/pls/grl-pls.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/libs/pls/grl-pls.c b/libs/pls/grl-pls.c
+index 62c578b..f6121cc 100644
+--- a/libs/pls/grl-pls.c
++++ b/libs/pls/grl-pls.c
+@@ -47,6 +47,10 @@
+ #include <totem-pl-parser.h>
+ #include <totem-pl-parser-mini.h>
+
++#ifndef TOTEM_PL_IS_PARSER(x)
++#define TOTEM_PL_IS_PARSER(x) TOTEM_IS_PL_PARSER(x)
++#endif /* TOTEM_PL_IS_PARSER */
++
+ /* --------- Constants -------- */
+
+ #define GRL_DATA_PRIV_PLS_IS_PLAYLIST "priv:pls:is_playlist"
+@@ -465,7 +469,7 @@ grl_pls_playlist_entry_parsed_cb (TotemPlParser *parser,
+ GRL_DEBUG ("%s (parser=%p, uri=\"%s\", metadata=%p, user_data=%p)",
+ __FUNCTION__, parser, uri, metadata, user_data);
+
+- g_return_if_fail (TOTEM_IS_PL_PARSER (parser));
++ g_return_if_fail (TOTEM_PL_IS_PARSER (parser));
+ g_return_if_fail (uri);
+ g_return_if_fail (metadata);
+ g_return_if_fail (user_data);
+--
+2.22.2
+