aboutsummaryrefslogtreecommitdiffstats
path: root/community/grpc/fix-install.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-07-02 10:29:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-07-04 06:59:51 +0000
commitae758ca47680934eb757dc1a3e28740097dd3695 (patch)
treecb5331a171fa5f4f8eab76cf830a03165ccfb0d6 /community/grpc/fix-install.patch
parent12f999a66711954da4ef0b4ef04a8e51da4952dc (diff)
downloadaports-ae758ca47680934eb757dc1a3e28740097dd3695.tar.bz2
aports-ae758ca47680934eb757dc1a3e28740097dd3695.tar.xz
community/grpc: fix install
fix the install error: make: execvp: /bin/sh: Argument list too long minor cleanup of cli subpackage
Diffstat (limited to 'community/grpc/fix-install.patch')
-rw-r--r--community/grpc/fix-install.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/community/grpc/fix-install.patch b/community/grpc/fix-install.patch
new file mode 100644
index 0000000000..999e446f11
--- /dev/null
+++ b/community/grpc/fix-install.patch
@@ -0,0 +1,15 @@
+fix the install error: make: execvp: /bin/sh: Argument list too long
+
+diff --git a/Makefile b/Makefile
+index 983d120..f74fa98 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2982,7 +2982,7 @@ install-headers_c:
+ install-headers_cxx:
+ $(E) "[INSTALL] Installing public C++ headers"
+ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
+- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
++ $(Q) for h in $(PUBLIC_HEADERS_CXX); do $(INSTALL) "$$h" $(prefix)/$$h || exit 1; done
+
+ install-static: install-static_c install-static_cxx
+