aboutsummaryrefslogtreecommitdiffstats
path: root/community/gsoap
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-02-21 12:29:56 +0200
committerprspkt <prspkt@protonmail.com>2019-02-21 14:12:23 +0200
commit6931c02bed8417d7cf6c411637e1ee269b9d1dcf (patch)
tree8bb68670ee12e03c9ac546f6a76bee511471ce90 /community/gsoap
parent71ecbadf2c4b2f69fb473d051177871e2895c78a (diff)
downloadaports-6931c02bed8417d7cf6c411637e1ee269b9d1dcf.tar.bz2
aports-6931c02bed8417d7cf6c411637e1ee269b9d1dcf.tar.xz
community/gsoap: upgrade to 2.8.80
Diffstat (limited to 'community/gsoap')
-rw-r--r--community/gsoap/APKBUILD8
-rw-r--r--community/gsoap/musl-fixes.patch52
2 files changed, 36 insertions, 24 deletions
diff --git a/community/gsoap/APKBUILD b/community/gsoap/APKBUILD
index 08d276af38..02f2b2f43c 100644
--- a/community/gsoap/APKBUILD
+++ b/community/gsoap/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: <xmingske@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gsoap
-pkgver=2.8.74
-pkgrel=1
+pkgver=2.8.80
+pkgrel=0
arch="all"
pkgdesc="Cross-platform C and C++ SDK for SOAP/XML Web services"
license="GPL-2.0-or-later gSOAP-1.3b"
@@ -32,6 +32,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="85284b88a94f07f433ffaeb9031c24d4c9c3eb82f8c590fa257cf9392fa0382cdcde5b3d5c7df903c6ddec41b876643b21ea24d18186b03db9dc8a4d6e8477ad gsoap_2.8.74.zip
-2b53a280b43d1ebee03760a69bba55ec214e9dfc1351808055df896d6985b55c2b112049e88a27ddfa322bb86b6aed889388349da2927f8fad698238143e952f musl-fixes.patch
+sha512sums="7018f9904d6b3cd5f0d6dacdd03e399fa01df450ec37a4fd29988657b639b86027da62ffc8b03b79a05547e80250fb974b56784fb57e4583899bc8c1958aa8e1 gsoap_2.8.80.zip
+97b4b932807b74436331e4a665a6f36f49e4533107d3948e45659d2cdf939c9d24650e7233e1a3a9e3e87db6a7821ab0a4502454d2579fff9e7a5f0b1f2cbb03 musl-fixes.patch
663fb1572e0e6283bb9ef994b2e2a0f828d25a69454447d5a2b602aa396c8fe57c1b3c4098e5c26603e693931ac17d8dc5702c8ef6a00b8fec6a43ff9317a05c musl-needs-_GNU_SOURCE-too.patch"
diff --git a/community/gsoap/musl-fixes.patch b/community/gsoap/musl-fixes.patch
index 7a8045cfe4..ae706d13be 100644
--- a/community/gsoap/musl-fixes.patch
+++ b/community/gsoap/musl-fixes.patch
@@ -1,28 +1,39 @@
---- a/gsoap/stdsoap2.c
-+++ b/gsoap/stdsoap2.c
-@@ -22111,7 +22111,7 @@
+--- a/gsoap/stdsoap2.c 2019-02-20 22:32:37.000000000 +0200
++++ b/gsoap/stdsoap2.c 2019-02-21 13:47:00.423192212 +0200
+@@ -5099,7 +5099,7 @@ tcp_gethost(struct soap *soap, const cha
+ return soap->error = SOAP_EOM;
+ return SOAP_OK;
+ }
+-#if defined(__GLIBC__) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__)
++#if defined(LINUX) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__)
+ if (gethostbyname_r(addr, &hostent, soap->buf, sizeof(soap->buf), &host, &soap->errnum) < 0)
+ host = NULL;
+ #elif defined(_AIX43) || ((defined(TRU64) || defined(HP_UX)) && defined(HAVE_GETHOSTBYNAME_R))
+Only in gsoap-2.8/gsoap: stdsoap2.c.orig
+--- a/gsoap/stdsoap2.cpp 2019-02-20 22:32:37.000000000 +0200
++++ b/gsoap/stdsoap2.cpp 2019-02-21 13:47:00.428192236 +0200
+@@ -5099,7 +5099,7 @@ tcp_gethost(struct soap *soap, const cha
+ return soap->error = SOAP_EOM;
+ return SOAP_OK;
+ }
+-#if defined(__GLIBC__) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__)
++#if defined(LINUX) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__)
+ if (gethostbyname_r(addr, &hostent, soap->buf, sizeof(soap->buf), &host, &soap->errnum) < 0)
+ host = NULL;
+ #elif defined(_AIX43) || ((defined(TRU64) || defined(HP_UX)) && defined(HAVE_GETHOSTBYNAME_R))
+@@ -22307,7 +22307,7 @@ soap_strerror(struct soap *soap)
{
#ifndef WIN32
# ifdef HAVE_STRERROR_R
--# if defined(_GNU_SOURCE) && !defined(__ANDROID__)
-+# if defined(_GNU_SOURCE) && !defined(__ANDROID__) && defined(__GLIBC__)
- return strerror_r(err, soap->msgbuf, sizeof(soap->msgbuf)); /* GNU-specific */
- # else
+-# if ((!defined(_POSIX_C_SOURCE) || !defined(_XOPEN_SOURCE) || _POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600) && !_GNU_SOURCE) || defined(__ANDROID__)
++# if ((!defined(_POSIX_C_SOURCE) || !defined(_XOPEN_SOURCE) || _POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600) && !_GNU_SOURCE) || defined(__ANDROID__) || !defined(__GLIBC__)
strerror_r(err, soap->msgbuf, sizeof(soap->msgbuf)); /* XSI-compliant */
---- a/gsoap/stdsoap2.cpp
-+++ b/gsoap/stdsoap2.cpp
-@@ -22111,7 +22111,7 @@
- {
- #ifndef WIN32
- # ifdef HAVE_STRERROR_R
--# if defined(_GNU_SOURCE) && !defined(__ANDROID__)
-+# if defined(_GNU_SOURCE) && !defined(__ANDROID__) && defined(__GLIBC__)
- return strerror_r(err, soap->msgbuf, sizeof(soap->msgbuf)); /* GNU-specific */
# else
- strerror_r(err, soap->msgbuf, sizeof(soap->msgbuf)); /* XSI-compliant */
---- a/gsoap/stdsoap2.h
-+++ b/gsoap/stdsoap2.h
-@@ -991,7 +991,7 @@
+ return strerror_r(err, soap->msgbuf, sizeof(soap->msgbuf)); /* GNU-specific */
+Only in gsoap-2.8/gsoap: stdsoap2.cpp.orig
+--- a/gsoap/stdsoap2.h 2019-02-20 22:32:37.000000000 +0200
++++ b/gsoap/stdsoap2.h 2019-02-21 13:47:00.428192236 +0200
+@@ -998,7 +998,7 @@ extern "C" {
# endif
#elif defined(SOCKLEN_T)
# define SOAP_SOCKLEN_T SOCKLEN_T
@@ -31,3 +42,4 @@
# define SOAP_SOCKLEN_T socklen_t
#elif defined(IRIX) || defined(WIN32) || defined(__APPLE__) || defined(SUN_OS) || defined(OPENSERVER) || defined(TRU64) || defined(VXWORKS)
# define SOAP_SOCKLEN_T int
+Only in gsoap-2.8/gsoap: stdsoap2.h.orig